Save All doesn't save *all* attachments of a mail

RESOLVED DUPLICATE of bug 243548

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 243548
14 years ago
8 years ago

People

(Reporter: hansen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: version 0.7+ (20040622)

When using Save All to save attachments of a mail, it only saves one or a couple
of files.
I can't reproduce if i send a message in TB to myself with several attachments.

Reproducible: Sometimes
Steps to Reproduce:
1. View mail with loads of attachments.
2. Right-click attachment-pane, Save All.

Actual Results:  
It saves one or a couple of files.

Expected Results:  
It should have saved all mails to selected folder.
(Reporter)

Updated

14 years ago
Summary: Save All doesn't save *all* files in mail → Save All doesn't save *all* attachments of a mail
(Q1) Can you attach the mail?
(1) Create a folder (assume folder name = "TEST")
(2) Copy the mail to "TEST" folder
(3) Compact "TEST" folder
(4) Copy file of "TEST"(instead of "TEST.msf") to a text file
(5) Edit the text file and replace sensitive information such as mail address
    to xxx@aaa.bbb.ccc
(6) Attach the text file to this bug (text/plain)

(Q2)Does problem also occur on Mozilla Mail&News?
(1) Copy file of "TEST" created at step(3) in (Q1)to Mozilla's mail directry
(2) Start Mozilla Mail&News -> Folder of "TEST" will appear
(3) Try to "Save All" for attachment.

(Q3) Thunderbird 0.9.1 is already released. Does problem occur on Thunderbird 0.9.1?
 
(Reporter)

Comment 2

14 years ago
well...after several tests it seems that it's an imap problem - it only appears,
when saving from imap - have tried different servers and types and it still occurs.

when i SaveAll, then it perhaps saves a file or two and if i SaveAll again it
saves the rest sometimes and other times i need to press SaveAll a couple of
times more...

A1: there's no need to add a mail, since it's imap - and the headers are no
different from others.

A2: no idea - ain't using moz

A3: there isn't any TB.9.1 - only .7.1 and i've been using that for a couple of
days and now i've moved onto .8beta(.7+)

don't know what's wrong with the imap, but i'm having some problems when just
opening mails, they turn to show up empty - and i'm not the only one - we're 20
people using TB as our mailclient.
> TB.9.1
Sorry, it was 0.7.1.

I saw some IMAP download related problems recently.
 Bug 243548 IMAP Attachment not fully downloaded
 Bug 242062 mpeg/avi attachments show the right size file
            but are saved/activated with trancated size

I do not know whether your problem and these bugs are same or not, but they
seems to be similar situation if there are somthing wrong in downloading IMAP
attachment.

Does problem occur even when all message data is downloaded localy(for example,
offline case)?
If problem occurs even after localy downloaded, something wrong may be in data
itself(Bug 242062 is possibly this case)  
But if problem only occurs when attached data is not downloaded yet, IMAP
protcol log is required for developers to analyze problem(Bug 243548 seems to be
this case).
See http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap   
(Reporter)

Comment 4

14 years ago
thanks - it was bug 243548, that i was looking for - it doesn't happend locally

sorry bout the duplicate and time!

-hansen

*** This bug has been marked as a duplicate of 243548 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

14 years ago
yahooo!

i can't reproduce this bug anymore with newest thunderbird 20040804

also see bug 243548
You need to log in before you can comment on or make changes to this bug.