FireFox process still running after window is closed

RESOLVED DUPLICATE of bug 239223

Status

()

RESOLVED DUPLICATE of bug 239223
15 years ago
14 years ago

People

(Reporter: lgjerstad, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When working with large number of tabs (e.g. reading news and opening each
article in a new tab) and then closing each tab using ctrl+w, closing the last
tab should terminate FireFox.  Instead, it closes the window, but leaves the
process running.  When this happens, the next time FireFox is opened, features
like the bookmark toolbar fail to initialize.  The only way to recover is to
kill the process using task manager.

Reproducible: Always
Steps to Reproduce:
1. Open a number of tabs, ~10
2. Close each tab using ctrl+w
3. Close last tab using ctrl+w (closing the window)

Actual Results:  
FireFox process remained active, but inaccessible.

Expected Results:  
The process should have terminated, or when FireFox is reopened, it should latch
onto the existing process (e.g. in Linux/mozilla, the script can be configured
to open a new tab when invoked with an existing process running)

*** This bug has been marked as a duplicate of 239223 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.