duplicate addressbook entries when using lists

RESOLVED DUPLICATE of bug 134590

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED DUPLICATE of bug 134590
14 years ago
14 years ago

People

(Reporter: Alex Dunkel, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: TB version 0.7 (20040616)

As discussed on mozillaZine (Addressbook lists: why duplicate entries created? 
by alexmoss: http://forums.mozillazine.org/viewtopic.php?
t=63918&highlight=addressbook+duplicate), the main addressbook is populated 
with individual entries *and* entries from any lists that have been created.  
This can be a problem because multiple lists may reuse individual email 
addresses, creating many duplicates in the main addressbook.  The mozillaZine 
post given above gives excellent examples.

(NOTE: If this is a duplicate of another bug, then the search engine for 
Bugzilla needs to be re-examined.  For one, add the ability to 
use "and", "+", "or", "-", and "not".  I'm tired of searching exhaustively for 
existing reports, reporting the bug I'm concerned about, then being informed 
that it's a duplicate.  And FYI: I have a Masters in Information Science, so I 
know how to use & write search engines.)

Reproducible: Always
Steps to Reproduce:
1. Create an addressbook card (and no lists) in a blank addressbook.
2. Now create a list and add a card that's the same as the one created in the 
previous step.
3. Look in the root of the addressbook.
Actual Results:  
The address book contains 2 identical cards and 1 list.

Expected Results:  
The address book should contain 1 entry and 1 list.  If the list is going to 
link back to the entries in the root of the addressbook, then it needs to 
avoid duplication of entries.

Comment 1

14 years ago
Hmm ... sounds like a dupe of  Bug 134590.

(In reply to comment #0)
> And FYI: I have a Masters in Information Science, so I 
> know how to use & write search engines.)
Really? ;-)) I did search for Product(Mailnews & TB) and Component(AB) for all
open bugs (incl. unconfirmed) with summary contains "duplicat".

Mozilla trunk build 2004062008 on WinNT4.
Confirming partly ... if I use an empty AB, create a card, create a list and add
this card per auto-complete to this list and press ok I show the card
duplicated. But if I go to another folder/AB and go back the display is fine,
only one card. Refresh problems? Same thing in bug 162934 comment 5.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 134590 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Address Book → Address Book
Product: Thunderbird → MailNews
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.