Closed Bug 248361 Opened 18 years ago Closed 14 years ago

Invalid rendering of Indic (Gurmukhi) text when justified.

Categories

(Core :: Internationalization, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sukhuk, Assigned: smontagu)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

Test URL:
http://www.5abi.com/gyan-vigyan/bhasha-vigyan/190603_sankat_dr-maheep1-U.htm

Although I have only tested this on Firefox, I presume the problem occurs
throughout the Mozilla family of products.  Under Windows, using Uniscribe (I
presume), Indic text (in this case Gurmukhi) will not render correctly at all. 
All vowel signs are spaced out, conjuncts aren't rendered nor are glyphs
repositioned.  However, if text is not justified but aligned either left, right
or centre, this problem does NOT occur.  This text renders just fine!

Internet Explorer 6 does not have this problem.

Reproducible: Always
Steps to Reproduce:
1. Install a Gurmukhi font (http://guca.sourceforge.net has one in the
Typography section)
2. Visit
http://www.5abi.com/gyan-vigyan/bhasha-vigyan/190603_sankat_dr-maheep1-U.htm

Actual Results:  
Invalid text that was justified but was of no use because it has dotted circles
everywhere! :D

Expected Results:  
It should have rendered justified text as Internet Explorer 6 does.
This is a well-known issue. See bug 218887. With the patch there, this can be
fixed. 
Status: UNCONFIRMED → NEW
Depends on: uniscribe
Ever confirmed: true
I can't really see this as a being fixed in Firefox 1.1 and even 1.5.  Is it
possible to do a check to see if any Indic characters are contained with a tag
that needs to be justified and if so ignore the justification rule?  This is
quite a major problem at the moment for Indic scripts especially when people
that make web pages and test them only in IE see no problem.

That way we can at least have a temporary fix until a more suitable solution is
implemented.
dupe of bug 240914?
There are a bunch of very similar bugs, some of which are listed in bug 297074
comment 2. I'm not really sure which one to dupe the others to :)
This seems to be fixed on current trunk.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.