Click two links in a row on the same page makes them one after the other in history.

RESOLVED DUPLICATE of bug 248376

Status

()

RESOLVED DUPLICATE of bug 248376
15 years ago
15 years ago

People

(Reporter: doom_duke, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

This might be similar to Bug 55784 in nature, but appears differently.

On any webpage, find two links that do not open in new windows. Click the first
one, then click the second link. The first link opens, then the second opens too
which will be the final page.
Now, click the back button, you go back to the first link rather than the
original page. This appears like the second link comes from the first link,
which is not. Similar when Forward button is clicked.

The timing is important. The 1st link should not open immediately, which allows
you some time to click the second link. It seems like this happens at a point
where the browser just received content from the 1st link, but has not started
rendering the page, then the second link is clicked. This case is reproducible.

Occasinally similar thing happens even when only one link is single-clicked.
The page is opened twice in a row. But this case is not as often as above, and
happens randomly. Do not know how to reproduce this case consistently.

I'm not sure if this is what's supposed to be. It's not critical, but I'm 
wondering could this behavior interfere with online shopping, or any page that
tracks user status?

Reproducible: Always
Steps to Reproduce:
1. Open a web page with multiple links that do not open in new windows.
2. Click one link, then click another link. Practice to find correct time interval
between the two clicks.
3.

Actual Results:  
It appears like: original page -> 1st link -> 2nd link, where 1st and 2nd links
are both from the original page.

Expected Results:  
Browser should open either the 1st, or the 2nd link, but not both in a row.

Comment 1

15 years ago
Duplicate of bug 248376

*** This bug has been marked as a duplicate of 248376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
(In reply to comment #1)
> Duplicate of bug 248376
> 
> *** This bug has been marked as a duplicate of 248376 ***

I'm sorry, I reloaded the page after posting. Could moderator deletes this dup?
Sorry for this.
You need to log in before you can comment on or make changes to this bug.