element and page finish rendering incorrectly formed HTML without warnings in the javascript console when using innerHTML in javascript

RESOLVED WONTFIX

Status

()

Core
HTML: Parser
--
minor
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: Jacob Jordan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040622 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040622 Firefox/0.8.0+

At the page http://xaxio.com/converged/contact2.php, an element is rendered
correctly, then changed using javascript and innerHTML to an element with an
attribute that is not closed properly.  Should this have some sort of warning,
or even render at all, since it is not closed properly?

Reproducible: Always
Steps to Reproduce:
1. go to http://xaxio.com/converged/contact2.php
2. press "ok" at the popup
3. view the source of the page to see that the <a href=' is not closed properly
in the innerHTML line

Actual Results:  
page rendered correctly

Expected Results:  
either a warning should have been generated in the javascript console, or the
element should not have rendered at all

no theme, winxp, 256 megs ram, 433 celeron processor, shell = bb4win

Updated

14 years ago
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: firefox.general → general
Version: unspecified → Trunk
probably a duplicate of some "make invalid html show an error" bug
Assignee: general → parser
Component: Browser-General → HTML: Parser
QA Contact: general
Well, I see this in the page source.
myElement.innerHTML += "<a href='mailto:customer" + "_" + "care" + "@" +
"converged.biz?subject=\"From%20Your%20Website\">customer" + "_" + "care" + "@"
+"converged.biz</a>";
It looks to me like valid html.

But I think that this bug otherwise would fall under bug 6211.
This is wontfix.  Warning for every single HTML issue like that would mean
hundreds to thousands of warnings for a typical web page, drowning out any
useful error diagnostics completely.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.