Crash when printing then closing the tab while the document is spooling [@ nsPrintEngine::ReflowPrintObject ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: u116418, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firehawk/0.9 (Lohvarn)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Firefox crashes if you try to print a page then quickly close the tab before the
document has spooled.

Reproducible: Always
Steps to Reproduce:
1. Open any web page.
2. File => Print => OK.
3. Quickly close the tab before the document is done spooling.

Actual Results:  
Firefox crashes and the document doesn't print.

Expected Results:  
Firefox should keep spooling the document and print it without crashing.

Comment 1

14 years ago
Lohvarn: Could you provide TalkBack incident id of crash?
Severity: minor → critical
Keywords: crash
(Reporter)

Comment 2

14 years ago
How do I do that? I couldn't seem to find that information when viewing details
in Talkback. Sorry first time I've used Talkback.

Comment 3

14 years ago
No problem =) To get the Talkback ID's go to your Firefox directory and go to
components/, there start talkback.exe, it'll give you a list with the IDs.
(Reporter)

Comment 4

14 years ago
Cool, it's incident TB178857Z.

Comment 5

14 years ago
TB178857Z:
nsPrintEngine::ReflowPrintObject 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2739]
nsPrintEngine::ReflowDocList 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2553]
nsPrintEngine::SetupToPrintContent 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2364]
nsPrintEngine::DocumentReadyForPrinting 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 2177]
XPCWrappedNative::CallMethod 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2027]
XPC_WN_CallMethod 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 941]
js_Interpret 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 2973]
js_Invoke 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 958]
js_InternalInvoke 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1035]
JS_CallFunctionValue 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c,
line 3607]
nsJSContext::CallEventHandler 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1297]
GlobalWindowImpl::RunTimeout 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 5156]
GlobalWindowImpl::TimerCallback 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 5515]
nsAppShellService::Run 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
main 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
kernel32.dll + 0x214c7 (0x77e814c7)

Stack look similar as one in bug 218304:
http://bugzilla.mozilla.org/show_bug.cgi?id=218304#c5
Assignee: firefox → core.printing
Component: General → Printing
Product: Firefox → Browser
QA Contact: firefox.general
Summary: Crash when printing then closing the tab while the document is spooling → Crash when printing then closing the tab while the document is spooling [ @ nsPrintEngine::ReflowPrintObject ]
Whiteboard: DUPEME
Version: unspecified → Trunk

Comment 6

14 years ago
Phong: bug 240490 may could fix also this bug - could you reproduce this bug
with Firefox 1.0.x or actual night build?
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> Phong: bug 240490 may could fix also this bug - could you reproduce this bug
> with Firefox 1.0.x or actual night build?

Still crashed on me with Firefox 1.0.1. The incident ID is: TB4090495Q

Comment 8

14 years ago
Ok, I'm marking this as NEW. (last stack is same as previous)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

12 years ago
Seen this in Firefox 1.5.0.5 on Linux (Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5)
works for me in Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a6pre) Gecko/20070613 Minefield/3.0a6pre ID:2007061304 [cairo]

Phong, do you still crash with a latest trunk build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ?
(Reporter)

Comment 11

11 years ago
Seems to work fine for me!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070614 Minefield/3.0a6pre

Thanks.
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a9pre) Gecko/2007092605 Minefield/3.0a9pre ID:2007092605

Also closing as works for me since the reporter confirm this, comment #10

-> Resolved works for me
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Summary: Crash when printing then closing the tab while the document is spooling [ @ nsPrintEngine::ReflowPrintObject ] → Crash when printing then closing the tab while the document is spooling [@ nsPrintEngine::ReflowPrintObject ]
Crash Signature: [@ nsPrintEngine::ReflowPrintObject ]

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.