Firefox opens a new tab/window when external link clicked.

RESOLVED DUPLICATE of bug 172962

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 172962
14 years ago
14 years ago

People

(Reporter: Ryan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Firefox .9 opens a new tab (Sometimes window) when an external link is clicked
even though i have made sure that advanced.system.supportDDEExec is set to true.
This is annoying and makes me want to roll back to .8 VERY badly.

Reproducible: Always
Steps to Reproduce:
1. Open browser, fire up a program that has a weblink (I.E. Yahoo Messenger or
an Email Client)
2. Click a link in the other program
3. Marvel at the new link or window.

Actual Results:  
Page loads in new tab or window

Expected Results:  
Reused the tab that was currently in focus.

I am using Tabbrowser Extensions and have it set up to only use one window w/
multiple tabs but it is not set up to open links in a new tab instead of in the
current one.

Comment 1

14 years ago
Can you reproduce this problem with Tabbrowser Extensions disabled?
Read the comments on bug 172962, if you have anything else to add, comment there.

Also notice that if extensions bugs should be filed in mozdev.

*** This bug has been marked as a duplicate of 172962 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
Yes, i can duplicate it w/ Extensions disabled
(Reporter)

Comment 4

14 years ago
The problem here is not that diff apps do diff things.... Firefox NEVER reuses
the current window like the old version did..... thats my problem.... the other
bug had the problem that some programs reused an old window and some used the
topmost one... my problem is different, i have everything set up right but
Firefox STILL refuses to use the topmost window.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
THIS IS A DUPLICATE

see here:
http://bugzilla.mozilla.org/show_bug.cgi?id=172962#c39

the new problem is know (first two paragraphs), alos the bug there isn't talking
aboput ome apps.

Also notice that the bug there is marked as blocking 1.0+, so it will probably
get fixed in the next release (it will fix this behavior).

Any objections?

Comment 6

14 years ago
Hm. I just upgraded to 0.9.1 and now it DOSEN'T make a new tab for external
links... and I'd rather it did. My old .8 setup with Tabbrowser Extensions
opened new tabs for external links, but slowed the browser to a crawl.

Comment 7

14 years ago
I hope this is the right bug report for the problem I have...

Ever since upgrading from .8 to .9 -- and now .9.2 (Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2) -- whenever I click
on a link in my email program a *new* copy of Firefox is loaded with that URL. 
Previously, the tab that had the focus of the already-running copy of the
browser is where the URL was sent.

Was that a configuration change, or is it part of this problem too?
*it's* a duplicate

*** This bug has been marked as a duplicate of 172962 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.