Dialogs (Preferences, etc.) don't display in Browser, but do in Mail

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: dlegate, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
Build Identifier: Mozilla 1.7 (old prefbar settings spoofs 1.4 at this point)

After installing 1.7 on Windows XP (over 1.6 originally, and then after
completely uninstalling (exception - kept my profile directories) no dialogs pop
up for me in the browser.  If I launch Mail/News, the dialogs work, but only
from the Mail/News window and menus.

Further, the Mail/News icon in the bottom left corner (and in fact, all the
icons down there) don't launch from the browser window and again work just fine
from the Mail/News window.  I have to start Mail/News from a Windows icon (start
menu/quick launch/destop, etc.) - it won't start from those icons, nor will it
start from the browser's Window menu.  The Window menu works fine from Mail/News.

Another concern I have that might affect this: installing 1.7 got rid of my
Prefbar extension, however my "Tabbed Browser Extensions" still appear to be
installed and working (which the installer says it will delete all extensions).
 How can I manually delete an extension?

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla Browser
2. Choose:
  a. Edit/Preferences (nothing happens)
  b. Window/Mail & Newsgroups (nothing happens)
  c. Edit/Find (nothing happens)
  d. Pretty much any dialog doens't show from the browser window.
3. Launch Mail/News
  a. Edit/Preferences now works
  b. Window menu items now work
4. Back to browser window:
  a. Form elements (input text, text areas, checkboxes, etc.) respond very
SLOWLY when clicked.  1.6 displayed no such delays.  Typing doesn't seem slow,
but clicks take a while to respond to (3-5 seconds or more sometimes).
Actual Results:  
From the browser window - no dialogs ever popped up.

From the Mail/News window, all dialogs work.

Form elements should respond immediately.

Expected Results:  
Dialogs should display/show/pop up.

Forms should be more responsive to mouse activity.

Comment 1

15 years ago
Did you try a clean new profile without any extensions? Could you there open the
pref dialog? Perhaps your old profile is corrupted or something with extensions.

Comment 2

15 years ago
http://extensionroom.mozdev.org/more-info/prefbar
http://extensionroom.mozdev.org/more-info/tbe

http://extensionroom.mozdev.org/uninstalling.html
describes how to uninstall an extension manually.
An extension can be installed in the program folder, or the profile.
TBE has a good history of breaking new Mozilla installations, so it is always a
good idea to deinstall TBE first, or have one profile without extensions, to be
able to start Mozilla when the other profiles with extensions are broken.
I edited the properties of my shortcuts to call mozilla.exe -ProfileManager
or mozilla.exe -P "herman", to start with the profile named herman.

If you have Netscape7 and Mozilla, you can get some useful info here, in english:
http://www.holgermetzger.de/etips6.html

Use a separate profile with Netscape and Mozilla
http://www.holgermetzger.de/efaqgeneral.html#18
(Reporter)

Comment 3

15 years ago
The following steps worked perfectly for me:

Go to my profile directory.  Delete the 'chrome' directory & all contents. 
Reinstall 1.7 and voila!  All my old prefs, bookmarks, etc. are still there an
none of the previous problems.  Had to reinstall my extensions & plugins as well
(as expected).

Thanks for everyone's input.

Dan
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 4

15 years ago
Nothing in Mozilla was broken or fixed.  (No Mozilla code checked in.)

->WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.