If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Title is not updated after listing a local directory

VERIFIED DUPLICATE of bug 22174

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 22174
18 years ago
13 years ago

People

(Reporter: Cyril Bortolato, Assigned: travis)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When a local directory is listed in mozilla, the window title is not updated.
It displays the title of the previously accessed URL.

Steps to reproduce:
1) launch mozilla. http://mozilla.org is loaded and the window title is
  "mozilla.org - Mozilla".
2) type in the URL of a local directory, for example file:/etc
3) the directory is listed. The window title still reads "mozilla.org -
Mozilla".

Expected result:
Title should change to something like: "Directory listing of /etc - Mozilla".

Platform:
Build ID=2000012209 on Linux.

Comment 1

18 years ago
Looked for a DUP, but couldn't find one. That doesn't change the fact that this 
is so not my bug. Enjoy! -> waterson
Assignee: vidur → waterson

Comment 2

18 years ago
don, someone on your team needs to figure this out. it's a
webshell/browser/front-end thing.
Assignee: waterson → don
(Reporter)

Comment 3

18 years ago
Looks similar to bug #22174

Comment 4

18 years ago
Travis, is this our bug?  Is it even a webshell issue?
Assignee: don → travis
Component: DOM Level 0 → Browser-General
Target Milestone: M14
(Assignee)

Comment 5

18 years ago
Did this use to work?  Basically titles have to originate from the viewer out.  
Is the directory content Viewer trying to set this somewhere?  DocShell does 
not query the content viewer for it's title.  The content viewers set their 
title up via the dom or directly calling docshell set title.  Who owns the 
directory viewer?
(Reporter)

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 22174 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verified dupe of bug 22174 Title data as displayed in bar not updated upon FTP 
loading
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.