Remember mail password doesn't work if password manager is not enabled

RESOLVED DUPLICATE of bug 90338

Status

MailNews Core
Database
RESOLVED DUPLICATE of bug 90338
14 years ago
10 years ago

People

(Reporter: Scott Baker, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

MailNews doesn't seem to remember account passwords unless the password manager
is enabled. This makes sense, EXCEPT that if you click the "remember this
password" box you are not prompted to start the password manager.

The only way I found to start the password manager is to visit a webpage with a
password, enable the password manager, and then check email. At this point the
remember password box functions as it should.

Reproducible: Always
Steps to Reproduce:
1. Start a fresh profile
2. Open email and configure an email account
3. Check the mail and check the "remember this password box"
4. Restart mozilla and check mail


Actual Results:  
The enter password box appears, despite me telling it to save it

Expected Results:  
It should have saved the password and used that password to login.

Not a real severe bug but it had me guessing for a while this morning. I
configure email FIRST and didn't go to a web page and thus the password manager
was never started. It took me a while to figure out why Mozilla kept prompting
me for my password.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 90338 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.