Dropping URI onto existing bookmark should prompt to replace

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
14 years ago
6 years ago

People

(Reporter: Mike Caines, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

It would be great if dropping a URI (e.g. dragged from location bar) onto an
existing bookmark in the bookmarks sidebar prompted the user to replace the
current bookmark URI with the one being dropped. This would be useful for
replacing broken links.

Reproducible: Always
Steps to Reproduce:
1. Drag and drop URI from location bar onto existing bookmark in bookmarks sidebar.
Actual Results:  
Unable to drop new URI onto existing bookmark. Can only insert before or after.

Expected Results:  
Prompt appears with text such as:
Are you sure you want to replace the bookmarks location? (yes/no)

Should this also replace the bookmark label? This could be a separate feature,
the ability to update bookmark labels upon visiting them.
Product: Browser → Seamonkey

Comment 1

13 years ago
similar to Bug 204667
Assignee: p_ch → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Assignee: nobody → nobody

Comment 2

6 years ago
Implementing this would make creating new bookmark with D&D more difficult because you would need to hit a small space between other bookmarks and in case of miss you get annoying Edit Bookmark dialog so proposing wontfix this
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 WONT]

Comment 3

6 years ago
Agreed. WONTFIX
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Updated

6 years ago
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 WONT] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.