Last Comment Bug 248567 - View and view submenus do not show checkmarks or radio button marks when using high contrast black colour scheme unless you mouse over them
: View and view submenus do not show checkmarks or radio button marks when usin...
Status: RESOLVED DUPLICATE of bug 245154
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: unspecified
: x86 Windows 98
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 17:13 PDT by David Ogilvie
Modified: 2007-06-12 11:44 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David Ogilvie 2004-06-24 17:13:42 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Toolbars, status bars and sidebar do not show whether they are
checked or not unless you mouse over them, at which point the
radio button idicator shows up temporarily.  In the submens 
toolbars, the checkmarks only show up if you mouse over them.
They will also show up if use arrow through the items on the 
menu.  The same is true for the submenu triangle - it will only
show up if that item has the mouse or keyboard focus.

Reproducible: Always
Steps to Reproduce:
1. Set colour shceme to "High Contrast Black" in Control Panel > Display >
Appearance.
2. Start FireFox.
3. Do Alt-V to bring up the View menu
4. Use up and down arrow to go through the first couple of menu items, or go
intp the ToolBars menu and browse through that.

Actual Results:  
As noted in the description above, radio button marks, checkmarks and submenu
triangles only appear when the menu item has mouse or keyboard focus.

Expected Results:  
Checkmarks, radio buttons and submenu indicators should 
always be drawn with the foreground colour of the current 
Windows colour scheme.

Accessibility issue.
Comment 1 William Swanson 2007-06-12 06:43:28 PDT
I can confirm on Windows Vista Ultimate and Windows XP SP2.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Comment 2 William Swanson 2007-06-12 06:51:39 PDT
Oops, this should probably be a dupe of bug 245154 – Black submenu arrow in menus (e.g. View->Toolbars)
Comment 3 Kevin Brosnan 2007-06-12 11:44:27 PDT

*** This bug has been marked as a duplicate of bug 245154 ***

Note You need to log in before you can comment on or make changes to this bug.