Add a toolbar button for "Delete Mail Marked as Junk in Folder"

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: kburwood, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: version 0.7 (20040616)

This is just a suggestion to add a toolbar button for the "Tools | Delete Mail
Marked as Junk in Folder" menu choice.  It would be nice to mark all the junk
mail and then just click on a toolbar button to delete it all, instead of having
to go into the menu.  There's plenty of room on the toolbar to fit the button.

Reproducible: Always
Steps to Reproduce:

Comment 1

15 years ago
Yes! and a keyboard shortcut could be nice... ctrl+j

Comment 2

14 years ago
also a key combination like CTRL+J would be usefull.

Comment 3

14 years ago
The delete junk button could be a popup button (like the get messages button).
Delete junk could be a sub button of the delete button.

Comment 4

14 years ago
i would actually prefer a single button rather than a dropdown. there is already
a dropdown in place on the "tools" menu, so deleting all junk mail is now a
two-click command. adding it as a dropdown button would make it remain a
two-click command, which is not an improvement over the current method. a
toolbar button that is abe to be added on a per-user basis seems like a better
option to me in terms of making things as simple and straightforward as possible.

keyboard shortcut would be greatly appreciated.

Comment 5

14 years ago
Just found this report and wanted to let you all know that I've just
filed a more general report on this for the Mozilla Application Suite.

https://bugzilla.mozilla.org/show_bug.cgi?id=278375

It doesn't mention the keyboard shortcut ideas though.
Please, feel free to amend it with these your ideas.
"Delete all Junk marked mails" can already be done easily by a few or several 
step operation.
 (1) View/Junk
     (Key board only operation is as follows)
       - Press TAB key until cursor moves to "View"
       - Press "Arrow key" until "Junk" is displyed in "View" choice
 (2) CTRL+A & DELETE(or SHIFT+DELETE)
     (No need to move cursor. Curson is on Thread pane.)
 (3) Change back to View/All
"Delete all Junk marked mails" will easily be achieved by Message Filter too, if
enhancement in filter condition will be implemented, for example,
 -  If Junk status is Junk, Then delete it
 -  If Junk score is geater than 50, Then move to Trah folder

I agree on that it is very convenient if 1-click menu or 1-shork-cut key is
implemented for such multiple step operation.
But I think something like "customizable menu/button and menu/button action",
"more easy way of filtering", "filter sceduling mechanism", "JavaScriptable
filtering" and so on is much better for simple operation request for multiple
step works.
For example, "customizable button/button action" is already implemented on
Opera, and the customization of it on Opera is not so difficult, although it can
not be said "customization is very very easy for any beginer".

To all of requesters of the enhancement: What do you think?

Comment 7

14 years ago
(In reply to comment #6)
> To all of requesters of the enhancement: What do you think?

I just want a toolbar button for this action.

(Reporter)

Comment 8

14 years ago
(In reply to comment #6)
> To all of requesters of the enhancement: What do you think?

It's a nice idea (always nice to have options).  But honestly, a delete junkmail button is the only major 
button that I feel is lacking in the toolbar.

You could always make a separate request for the customizable buttons if you want; wouldn't hurt.
(In reply to comment #8)
> You could always make a separate request
All enhancements I mentioned in my comment #6 are already requested ones.
For example, Bug 80439 is "JavaScriptable filtering", which is expected to be 
implemented in future, although never be in near future...
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 11

13 years ago
This would still be nice.

Comment 12

13 years ago
I just voted for this bug, because that's really the proper way for people to say, "yes, I'd like this feature/fix also!", but I also wanted to add a clarification.

I agree completely with comments 4, 7, and 8.  A separate button that has the same functionality as "Tools -> Delete Mail Marked as Junk in Folder" is exactly what I would like.

BTW, I don't think this enhancement is limited to PC hardware or Windows 2000.

Comment 13

13 years ago
*** Bug 329000 has been marked as a duplicate of this bug. ***
QA Contact: front-end

Comment 14

11 years ago
I think there is an option for this with the extension

where in rclick on toolbar/customize you find the "delete junk" button
https://addons.mozilla.org/en-US/thunderbird/addon/2377
( http://codefisher.org/toolbar_button/button_list )

and a contextual del junk option in
https://addons.mozilla.org/en-US/firefox/addon/149

If this works, then the issue remains only if you want it in the main/default app. If we can consider this an option that can be kept in extensions, then may just mark this bug as Works For Me, if not, it remains to be established if that is going to make it in default set of buttons ..

Comment 15

11 years ago
The extension works fine for me. I would keep this option out of main/default application in this case.

Comment 16

11 years ago
I would too (comment 15) in which case I would mark it as "works for me"
But i would wait for Ken (reporter) or others to see if different opinion ..

(+ that buttons extension is clearly presenting tonz of buttons for all to pick their favorite for cases like this, IMO ..)
(Reporter)

Comment 17

11 years ago
Regarding comments 14, 15 & 16.  I've been using the "delete junk" addon for quite some time now actually--found it a couple years ago.

To me, this particular button still seems like basic functionality that you shouldn't need an addon for.  However, since there already is an addon that exists, plenty of people know about, and works just fine, I don't have any problem setting this to "Works for me".  It'll at least get one item off the open bugs list.

Unless there are any objections, I'll set it to "Works for Me" by the end of the week.
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 18

11 years ago
Setting the status to "Works for Me", since there's an add-on that performs this functionality and nobody has posted any objections to closing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 19

2 years ago
The extension doesn't work with the current version of Thunderbird.
An extension for this very essential functionality is not a solution.

Should I create a new bug? I think yes.
You need to log in before you can comment on or make changes to this bug.