Body Component in CSS of site, loading incorrectly

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Suzanne Ouimet, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

In the page http://www.billboardwebservices.com/TestSites/Danica/index.htm, the
image at the top of the page is designated in CSS in "body" as center,top.  It
is coming up at the left margin in Firefox browser, which is incorrect.



Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
The CSS instructions should be followed.

Comment 1

14 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040624
Firefox/0.9.0+

That page fails XHTML & CSS validation, btw.  Since it has a DOCTYPE, it gets
rendered in standards compliance mode.

Comment 2

14 years ago
this is caused by an invalid line in the CSS file.  

the offending line is:
background-position: top center 10px;

removing the 10px from the end of it puts the image where it is supposed to be
(top and center).  this property only takes 2 values, not 3.  you can read more
about it at http://www.w3schools.com/css/pr_background-position.asp

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Web Site → General
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.