Closed Bug 248618 Opened 19 years ago Closed 16 years ago

Western text specified as "Geeza Pro" isn't shown on Mac

Categories

(Core Graveyard :: GFX: Mac, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: harunaga, Assigned: smontagu)

References

()

Details

(Keywords: intl)

Attachments

(1 file)

This is probably Mac only.
Mac OS X has some font which doesn't contain Western characters ([0-9]
[A-Z][a-z]).
"Geeza Pro (Bold)" is one of them.
If Western text is specified as "Geeza Pro", it's displayed as square
on Mac.

Safari 1.2.2, Opera 7.50 and Mac IE 5.2.3 don't have this problem on
Mac OS 10.3.4.
Attached image screenshot
Changeing component, and it's probably related to bug 120401, so i'm adding
dependence.
Component: Internationalization → GFX: Mac
Depends on: 120401
Does it work if you write <p><font face="Geeza Pro"> instead of <p
style="font-family: 'GeezaPro';"> ?
(In reply to comment #3)
> Does it work if you write <p><font face="Geeza Pro"> instead of <p
> style="font-family: 'GeezaPro';"> ?

No, it doesn't work either.

*** This bug has been marked as a duplicate of 179945 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
No. this is not a dup of bug 179945.
Alphabet and numeric characters specified as "Symbol" are rendered
with Mozilla on Mac.
Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
That doesn't necessarily mean it isn't a duplicate. The Symbol font (big "S")
has special-casing in gfx/src/mac/fontEncoding.properties. If Geeza Pro is a
symbol font (small "s"), which it seems to be from the test case, it requires a
version of the patch from bug 94319 for Mac. That's bug 179945.
This looks fixed to me in cairo-cocoa (our old friend busted Mac font code/fallback)....
yes, trunk-20061130 on OS 10.3.9 doesn't have this problem.
-> WFM
Status: REOPENED → RESOLVED
Closed: 19 years ago16 years ago
OS: Mac OS X 10.2 → Mac OS X 10.3
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.