Closed Bug 248669 Opened 19 years ago Closed 19 years ago

Add a right click context menu to the back and forward menus

Categories

(Firefox :: Menus, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

VERIFIED WONTFIX

People

(Reporter: mmortal03, Assigned: bugzilla)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7) Gecko/20040624 Firefox/0.9.0+
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7) Gecko/20040624 Firefox/0.9.0+

When one right clicks the back or foward buttons, a menu pops up. But, when one
right clicks one of *those* sites listed in this menu, instead of getting a
context menu, the same behavior as a left click (it goes to that page) is executed. 

What I propose is a context menu to pop up on top of this primary menu when
right clicking on these back and foward button history entries, as well as when
right clicking the history entries in the Go menu. I think most effectively, the
context menu options would be: Open (default), Open in New Window, and Open in
New Tab (which happen to be the applicable options taken directly from the
Bookmarks right click context menu). These options would coincide with and
compliment the functionality given by the middle click enhancement of Bug 202819
"Middle mouse click on the back button opens previous page in new tab
(enhancement)" and Bug 214816 "Middle click on links in go menu does not open a
new tab", but would also dually serve as an alternative or replacement option
for users who happen to have their middle click functionality disabled,
unavailable, or assigned to alternative uses.

Reproducible: Always
Steps to Reproduce:
1.  Right click on entries in the back, foward, and Go menus



Actual Results:  
In the Back and Foward menus, the right click does the same as a left click and
opens the page in the current window.
In the Go menu, a right click does nothing.

Expected Results:  
Expected results:
A context menu opens up with options when entries are right clicked.
OS: Windows ME → All
You can ctrl+click if you don't have a middle mouse button.  Having a context
menu would be better in case you want to do it with one hand, though, and it
would be easier to discover.  

The only problem is that on Windows, it's standard for context menus to respond
to right-click in the same way they respond to left-click.  I don't know how
many users normally right-click context menu items rather than left-clicking them.
This is a wontfix, because this is non-standard UI. It's pretty universal that
left click == right click in context menus. Plus, now we have [ctrl|shift]+click
modifiers on back/forward/go menus, so this is not really necessary.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
I can understand this logic for the right click context menu of the back and
foward buttons, that makes sense.  Remember though, the back and foward button
menus also act as *left* click drop down menus.  I know it is the same menu, so
in this case, I am sure it just wants to be kept like IE, so I won't push the
issue. :)

The Go menu, however, is not a context menu, and it *could* benefit from a
context menu in the same way that the Bookmarks menu does and stay within the
standard UI practice.

I have edited the summary and request that the bug be reopened as "Add a right
click context menu to the Go menu".
Summary: Add a right click context menu to the back and foward button and Go menus → Add a right click context menu to the Go menu
It would be better if you filed a new bug for that instead of morphing this one,
even though you originally intended this bug to cover both.
Summary: Add a right click context menu to the Go menu → Add a right click context menu to the back and forward buttons
A new bug report has been created for the Go menu enhancement request.  Bug 248963.
Summary: Add a right click context menu to the back and forward buttons → Add a right click context menu to the back and forward menus
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.