Closed Bug 248676 Opened 20 years ago Closed 20 years ago

M17 crash [@ SBCopyDir32To16Clip]

Categories

(Core Graveyard :: Image: Painting, defect)

Other Branch
PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 247542

People

(Reporter: jay, Assigned: jdunn)

Details

(Keywords: crash, topcrash)

Crash Data

Not sure what's going on with this crash on MacOS X, but there are a lot of them
happening with Mozilla 1.7. The component might need to be changed. Here are a
couple of sets of crash from Talkback:

Rank    StackSignature    Count  

4   SBCopyDir32To16Clip   29 
 
====================================================================================================
     Count   Offset    Real Signature
[ 10   SBCopyDir32To16Clip() 850060e9 - SBCopyDir32To16Clip() ]
[ 10   SBCopyDir32To16Clip() 850060e9 - SBCopyDir32To16Clip() ]
 
     Crash date range: 23-JUN-04 to 24-JUN-04
     Min/Max Seconds since last crash: 4636 - 74278
     Min/Max Runtime: 5696 - 449147
 
     Count   Platform List 
     14   MacOS X [Darwin 6.8]    
     6   [Darwin 7.4.0]      
 
     Count   Build Id List 
     20   2004061617
 
     No of Unique Users         9
 
 Stack trace(Frame) 

	 SBCopyDir32To16Clip()  
	 SBCopyDir32To16Clip()   
 
     (165916)	Comments: New york times again
     (165916)	Comments: New york times again
     (163714)	URL: http://www.wsdot.wa.gov/traffic/default.aspx?cam=1241
     (163714)	URL: http://www.wsdot.wa.gov/traffic/default.aspx?cam=1241
     (163146)	URL: www.sfgate.com
     (163146)	URL: www.sfgate.com
     (163090)	URL: ebay.com
     (163090)	URL: ebay.com
 
====================================================================================================
     Count   Offset    Real Signature
[ 2   SBCopyDir32To16Clip() 88c673fa - SBCopyDir32To16Clip() ]
[ 2   SBCopyDir32To16Clip() 88c673fa - SBCopyDir32To16Clip() ]
 
     Crash date range: 24-JUN-04 to 24-JUN-04
     Min/Max Seconds since last crash: 107 - 3989
     Min/Max Runtime: 3989 - 133104
 
     Count   Platform List 
     2   MacOS X [Darwin 6.8]    
     2   [Darwin 7.4.0]      
 
     Count   Build Id List 
     4   2004061617
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 SBCopyDir32To16Clip()  
	 SBCopyDir32To16Clip()  
	 OneSrcOneDst()  
	 BitsDevLoop()  
	 CommonBits()  
	 CopyMask()  
	 nsImageMac::CopyBitsWithMask()
[/builds/release/1.7/mozilla/gfx/src/mac/nsImageMac.cpp  line 774] 
	 nsImageMac::Draw()	[/builds/release/1.7/mozilla/gfx/src/mac/nsImageMac.cpp 
line 189] 
	 nsRenderingContextImpl::DrawImage()
[/builds/release/1.7/mozilla/gfx/src/shared/nsRenderingContextImpl.cpp  line 710] 
	 nsImageFrame::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsImageFrame.cpp  line 1308] 
	 nsContainerFrame::PaintChild()
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp  line 132] 
	 nsBlockFrame::PaintChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 683] 
	 nsHTMLContainerFrame::PaintDecorationsAndChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp  line
141] 
	 nsBlockFrame::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 5292] 
	 nsContainerFrame::PaintChild()
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp  line 132] 
	 nsBlockFrame::PaintChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 683] 
	 nsHTMLContainerFrame::PaintDecorationsAndChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp  line
141] 
	 nsBlockFrame::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 5292] 
	 PresShell::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsPresShell.cpp  line 5567] 
	 nsView::Paint()	[/builds/release/1.7/mozilla/view/src/nsView.cpp  line 260] 
	 nsViewManager::RenderDisplayListElement()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 1429] 
	 nsViewManager::RenderViews()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 1347] 
	 nsViewManager::Refresh()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 906] 
	 nsViewManager::DispatchEvent()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 704] 
	 HandleEvent()	[/builds/release/1.7/mozilla/view/src/nsView.cpp  line 80] 
	 nsWindow::DispatchEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 2024] 
	 nsWindow::DispatchWindowEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 2047] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1731] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::PaintUpdateRectProc()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1313] 
	 nsWindow::HandleUpdateEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 70] 
	 nsMacEventHandler::UpdateEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacEventHandler.cpp  line 1440] 
	 nsMacEventHandler::HandleOSEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacEventHandler.cpp  line 515] 
	 nsMacWindow::DispatchEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacWindow.cpp  line 282] 
	 nsMacMessagePump::DispatchOSEventToRaptor()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 589] 
	 nsMacMessagePump::DoUpdate()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 521] 
	 nsMacMessagePump::DispatchEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 451] 
	 nsMacMessagePump::DoMessagePump()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 312] 
	 nsAppShell::Run()	[/builds/release/1.7/mozilla/widget/src/mac/nsAppShell.cpp 
line 114] 
	 mozilla-bin + 0xb53c (0x0000b53c)  
	 mozilla-bin + 0xba80 (0x0000ba80)  
	 mozilla-bin + 0x8724 (0x00008724)  
	 mozilla-bin + 0x85a4 (0x000085a4)  
	 SBCopyDir32To16Clip()  
	 SBCopyDir32To16Clip()  
	 OneSrcOneDst()  
	 BitsDevLoop()  
	 CommonBits()  
	 CopyMask()  
	 nsImageMac::CopyBitsWithMask()
[/builds/release/1.7/mozilla/gfx/src/mac/nsImageMac.cpp  line 774] 
	 nsImageMac::Draw()	[/builds/release/1.7/mozilla/gfx/src/mac/nsImageMac.cpp 
line 189] 
	 nsRenderingContextImpl::DrawImage()
[/builds/release/1.7/mozilla/gfx/src/shared/nsRenderingContextImpl.cpp  line 710] 
	 nsImageFrame::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsImageFrame.cpp  line 1308] 
	 nsContainerFrame::PaintChild()
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp  line 132] 
	 nsBlockFrame::PaintChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 683] 
	 nsHTMLContainerFrame::PaintDecorationsAndChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp  line
141] 
	 nsBlockFrame::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 5292] 
	 nsContainerFrame::PaintChild()
[/builds/release/1.7/mozilla/layout/html/base/src/nsContainerFrame.cpp  line 132] 
	 nsBlockFrame::PaintChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 683] 
	 nsHTMLContainerFrame::PaintDecorationsAndChildren()
[/builds/release/1.7/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp  line
141] 
	 nsBlockFrame::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsBlockFrame.cpp  line 5292] 
	 PresShell::Paint()
[/builds/release/1.7/mozilla/layout/html/base/src/nsPresShell.cpp  line 5567] 
	 nsView::Paint()	[/builds/release/1.7/mozilla/view/src/nsView.cpp  line 260] 
	 nsViewManager::RenderDisplayListElement()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 1429] 
	 nsViewManager::RenderViews()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 1347] 
	 nsViewManager::Refresh()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 906] 
	 nsViewManager::DispatchEvent()
[/builds/release/1.7/mozilla/view/src/nsViewManager.cpp  line 704] 
	 HandleEvent()	[/builds/release/1.7/mozilla/view/src/nsView.cpp  line 80] 
	 nsWindow::DispatchEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 2024] 
	 nsWindow::DispatchWindowEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 2047] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1731] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::UpdateWidget()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1768] 
	 nsWindow::PaintUpdateRectProc()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 1313] 
	 nsWindow::HandleUpdateEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsWindow.cpp  line 70] 
	 nsMacEventHandler::UpdateEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacEventHandler.cpp  line 1440] 
	 nsMacEventHandler::HandleOSEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacEventHandler.cpp  line 515] 
	 nsMacWindow::DispatchEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacWindow.cpp  line 282] 
	 nsMacMessagePump::DispatchOSEventToRaptor()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 589] 
	 nsMacMessagePump::DoUpdate()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 521] 
	 nsMacMessagePump::DispatchEvent()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 451] 
	 nsMacMessagePump::DoMessagePump()
[/builds/release/1.7/mozilla/widget/src/mac/nsMacMessagePump.cpp  line 312] 
	 nsAppShell::Run()	[/builds/release/1.7/mozilla/widget/src/mac/nsAppShell.cpp 
line 114] 
	 mozilla-bin + 0xb53c (0x0000b53c)  
	 mozilla-bin + 0xba80 (0x0000ba80)  
	 mozilla-bin + 0x8724 (0x00008724)  
	 mozilla-bin + 0x85a4 (0x000085a4)   
 
     (165897)	URL: wired.com
     (165897)	URL: wired.com

*** This bug has been marked as a duplicate of 247542 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
Crash Signature: [@ SBCopyDir32To16Clip]
You need to log in before you can comment on or make changes to this bug.