hsbc.com.au - Does not allow logon to Internet Banking with mozilla

RESOLVED DUPLICATE of bug 205631

Status

--
enhancement
RESOLVED DUPLICATE of bug 205631
14 years ago
3 years ago

People

(Reporter: sipowitzxlx, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616


Identifies the browser correctly based on some javascript - however they refuse
to accept Mozilla as a valid browser implying crazy logic.

Crazy logic = IE is safe and Mozilla is not

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.hsbc.com.au
2. Click on Internet Banking
3. Make a sad face

Actual Results:  
I had a temper tantrum

Expected Results:  
Logged in as per IE login



I'd imagine many people experience this same bug on various banking and
financial sites around the world.

It's not so much a bug but a needed feature enhancement to fool sites into
thinking the browser is IE like Opera can do (poorly)

Comment 1

14 years ago
seems to be a bug 205631 dupe
Assignee: general → english-other
Component: Browser-General → English Other
Product: Browser → Tech Evangelism
QA Contact: general → english-other
Summary: Does not allow logon to Internet Banking with mozilla → hsbc.com.au - Does not allow logon to Internet Banking with mozilla
Version: Trunk → unspecified

Comment 2

14 years ago
Looks like a duplicate, but it also works for me. 
I just went to that site and I can get to the page with the login form. I don't
have an account, so I couldn't get further.
I'm using Firefox 0.8 on Win2k. I see that these two bugs are reported on Linux.

Reporter: did you see this on Windows too? You said OS - All in your report.

Comment 3

14 years ago
it might be only an issue on Linux...

*** This bug has been marked as a duplicate of 205631 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.