adding search engines silently fails when searchplugins/ isn't writable

VERIFIED DUPLICATE of bug 232638

Status

()

Firefox
Search
--
major
VERIFIED DUPLICATE of bug 232638
13 years ago
11 years ago

People

(Reporter: Andrew Sayman, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040623 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040623 Firefox/0.9

If searchplugins/ isn't writable, then adding engines fails without an error
message. The new search engine simply isn't added. 

Reproducible: Always
Steps to Reproduce:
1. cd firefox/
2. chmod 555 searchplugins/
3. start firefox
4. Add an engine

Actual Results:  
The engine isn't added to the list of available engines and no appropriate error
message is displayed.

Expected Results:  
An error message explaining that write permissions haven't been granted for the
target directory. Not only will this explain the failure, but it will help to
fix it yourself. It took me quite some time to find the searchplugins directory
and set it to writable when I first ran into this issue.

I'm labelling this as major, because it seems to affect a lot of linux users.
Permission issues are a common problem, but we need to know that's the issue to
fix it.

Comment 1

13 years ago
This problem also hits Windows users, if their Network administrator wants to
provide a shared installation. Search plugins should be stored in the users
profile directory. I don't see why they are stored into the global directory anyway.
(Reporter)

Comment 2

13 years ago
This bug probably affects all platforms. I can only show it on linux though.

Comment 3

13 years ago
Well, I'll confirm it for Windows XP.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Comment 4

13 years ago
This happens in gentoo too (Bugzilla Bug 49758 - [Adding engines to Mozilla
Firefox doesn't work] on bugs.gentoo.org).  They are refusing to fix it, and
they're saying its an upstream bug.. pleeeeeeease fix this issue.. make it in
your home directory instead of system wide. :).  Or atleast pop up an error
message saying you can't write to the directory you want... because right now
the behavior is just confusing, and the user is left wondering why he can't add
engines.

Comment 5

13 years ago
OS -> All

Confirming based on comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
(Assignee)

Comment 6

13 years ago
This bug implies that 'add engine' will be broken for every distro-installed
firefox.
The searchplugin directory should belong to the profile directory.
I'll try to have a fix for 1.0.
(Assignee)

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 232638 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

13 years ago
Is this really a dup of that though? I intended this bug to be less about the
fact that it's a bad directory to write search plugins, and more about the fact
that there is no intelligent response to this problem by the application. It
doesn't matter where searchplugins/ is, there should be a message if it's
unwritable.

Sometimes even the home directory isn't writable for some reason. Because that
doesn't happen very often, it can be very frustrating when apps just assume that
it is writable and don't mention when that assumption has broken down.

Comment 9

13 years ago
In that case then bug #237573 is probably a better place to continue.

-Thue

(In reply to comment #8)
> Is this really a dup of that though? I intended this bug to be less about the
> fact that it's a bad directory to write search plugins, and more about the fact

Updated

13 years ago
Blocks: 259072

Updated

13 years ago
No longer blocks: 259072
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.