Incorrect layout on page

RESOLVED DUPLICATE of bug 105520

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 105520
14 years ago
14 years ago

People

(Reporter: jst, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
This could very well be an IE bug, but I don't know gecko layout internals well
enough to say, so I'm filing this just to get this tracked...

Loading that page, you get a floating div with a movie ad on top of other
content in the main table on the page. Load the same page in IE and the ad is at
the bottom of the left column. I minimized this down to a small HTML file with
just a few divs and a table. Testcase coming up.
(Reporter)

Comment 1

14 years ago
Created attachment 151767 [details]
Testcase
Created attachment 151769 [details]
Another testcase

I made a different testcase based on that site. I could not really see the
problem with your testcase. I hope you don't mind.

This testcase shows that the table doesn't get positioned beneath the two
floats, as I think it should.
(Reporter)

Comment 3

14 years ago
The problem with the initial testcase is that the two pieces of content are next
to eachother, the green table should be underneath the box. Is that not what you
see?
(In reply to comment #3)
> The problem with the initial testcase is that the two pieces of content are next
> to eachother, the green table should be underneath the box. Is that not what you
> see?
Yes, that's what I see. They are next to eachother. I got confused about the div
tags, I guess. Sorry.
Maybe this is the same as bug 105520?

Comment 5

14 years ago
Created attachment 151773 [details]
Yet another testcase

we need more complicated testcases ;-)
Looking at previous testcase, I put the table in a div, and was astonished when
the div was rendered at the left, and the table outside the div.
Four DIVS are contained in the DIV with the red border. The first of these
DIVs, the yellow one at the right, has a height specified, but this height is
ignored by the containing div. Opera fits the height of the containing DIV so
that the red border includes all 4 contained DIVs.
The testcase in comment 2 shows bug 14984.  That's not what's going on in
comment 1, though.  That testcase is showing bug 105520.

I have no idea what the testcase in comment 5 is showing, since it's got so much
random stuff and no clear explanation of what the expected rendering is.

So based on all that, marking duplicate of bug 105520.

*** This bug has been marked as a duplicate of 105520 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.