If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

toolbar buttons start to multiply with theme changes

RESOLVED DUPLICATE of bug 226791

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 226791
13 years ago
9 years ago

People

(Reporter: Ken Yan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.8

Firefox creates duplicates of all the toolbar buttons and location/search boxes
when the theme is changed back and forth. (So you're left with two back buttons,
two forwards.. and it's ratherly troublesome to remove.) There are specific
conditions which this bug occurs, I've only found one that works every time.

Reproducible: Always
Steps to Reproduce:
1. Spawn a brand new mozilla firefox instance. 
2. Open a new window, which at this point you should have two windows. 
3. On the second window (not tested on the first) go to any website, like this one.
4. Now select Tools/Themes. 
5. Change to the modern theme
6. Change back to default
7. Repeat steps 5 and 6.
8. Repeat either step 5 or 6 to create more duplicates if desired (naturally you
can't repeat step 5 if you just performed it.)
Actual Results:  
You should notice that the toolbar buttons have duplicated! There are now two
back buttons, forward buttons, locations, etc. If you've performed step 8, there
should be three, etc.

Expected Results:  
Nothing.

For me, this occurs with firefox default 2.0 and firefoxmodern 0.71 with both
firefox 0.8 and firefox 0.9. Not tested on other themes or browsers.
(Reporter)

Comment 1

13 years ago
despite what the user-agent says, firefox (help/about) reports that it's running
version 0.9.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 226791 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.