The Find feature interrupts typing in a java textbox

RESOLVED DUPLICATE of bug 212239

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 212239
14 years ago
13 years ago

People

(Reporter: Carson True, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

The textbox in the submitted Java applet will sometimes be interrupted by the
find feature included in Firefox, so it will deselect the textbox and attempt to
find a link on the page matching the text that was interrupted

Reproducible: Sometimes
Steps to Reproduce:
1. Go to submitted link (obviously)
2. Start typing (may take a few tries)
3. Eventually, textbox will deselect, and Firefox will begin hunting for links
with the entered text

Actual Results:  
Firefox deselected the textbox and did as I said

Expected Results:  
It should have just let me continue typing, without interrupting the Java applet.

Updated

14 years ago
Assignee: mscott → firefox
Component: General → General
Product: Thunderbird → Firefox
QA Contact: firefox.general

Comment 1

14 years ago
I'm also seeing this in yahoo web messenger. It might be a duplicate of bug 101082.

Comment 2

13 years ago
I have had this problem as well - sometimes, and not with java specifically
(with other textboxes such as javascript as well).  I have seen no pattern on
causes, but it's always specific to one tab (other open tabs are fine- i often
browse with a dozen or more).  

It is specific to the ' character (apostrophe), in that the apostrophe character
when typed when this bug is occurring will cause the next character typed to
bring up the find menu (sort of like an escape character?)  The character
appears in the textbox - so you see "can't" but then nothing else typed, as it
all goes into the find box of course.  Hitting Esc will clear the find box and
return to normal (but hitting ' will again trigger the find box).

When this bug is occurring, it also disables the arrow keys and home/end/etc.
functionality (presumably it has some sort of dependence on escape codes?).  It
does NOT seem to be a keyboard related occurrence (ie the ctrl key becoming
locked in or something), I can fix those manually and not this.

It occurrs to me most often when replying to the forums on apolyton.com (they
use a VBB style forum, using JavaScript forms).  It does not reappear in a new
tab or window once it occurs once necessarily, although it can reappear later
during the same session (just as likely as if it were happening for the first time.)

Comment 3

13 years ago
When typing e-mails in gmail, every time I type an apostrophe the find dialog
comes up and interrupts my mail.  It's really annoying!!!

*** This bug has been marked as a duplicate of 212239 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.