Transparent GIF images are corrupt at low color depth

RESOLVED DUPLICATE of bug 239701

Status

()

--
major
RESOLVED DUPLICATE of bug 239701
14 years ago
14 years ago

People

(Reporter: alex, Assigned: jdunn)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040625
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040625

When I set my display to "thousands" of colors, GIF images with transparent
pixels are corrupted. With "millions" of colors, the problem disappears. The
problem extends to Mozilla's own Alert icon (exclamation mark in yellow triangle.)

Reproducible: Always
Steps to Reproduce:
1. set display to "thousands of colors"
2. type in a bogus url, e.g. "bogus:" in the address bar
3. press "enter" and observe the alert icon.

Actual Results:  
The alert icon comes through grainy and corrupted. 

Expected Results:  
Should have displayed a normal looking alert icon.

Comment 1

14 years ago
WFM / Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040621 +
Nvidia TNT2 @ 800x600x8
Maybe this is video card related and not Mozilla related? I have another TNT2
that showed corrupted alert icons in Windows 98 and it was viodecard BIOS related.
(Reporter)

Comment 2

14 years ago
It's probably OS related. I'm running Mac OS X v. 10.2.8 I noticed it first in
Camino 8. There was no such problem in Camino 7, or in Firefox 8 for Mac. I have
a beige G3 with stock ATI video card. But it does show up in the June 25 build
of Mozilla.
(Reporter)

Comment 3

14 years ago
I have determined that this bug cropped up in Mozillia 1.7 Beta. (The probem is
absent in 1.7 Alpha.) There is a clue in the 1.7 Beta release notes: "Very wide
images (more than 4095px) will now display on Mac."
(http://mozilla.org/releases/mozilla1.7b/README.html#new)
Known issue.  See duplicate for explanation.

*** This bug has been marked as a duplicate of 239701 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.