Placement of divs incorrect on first page load if image size not known.

RESOLVED DUPLICATE of bug 242159

Status

()

Core
Layout
--
trivial
RESOLVED DUPLICATE of bug 242159
14 years ago
14 years ago

People

(Reporter: Jesse Chisholm, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

In the page at http://2-4_marines.bravejournal.com/, the top DIV contains an
image with no pre-known size.  The DIV's size is calculated based on the assumed
size.  Later DIVs have their placement calculated based on this DIV's size. 
When the image finally loads, the DIV it is in has its size recalculated.  Nodes
whose placement depends on the size of the DIV in question _BUT have already
been placed_ do not get their placement recalculated.


Reproducible: Always
Steps to Reproduce:
1. Clear Page Cache
2. Navigate to http://2-4_marines.bravejournal.com/
3. Notice placement of the various DIVs
   e.g. Overlapping when they obviously shouldn't
4. Reload page
5. Notice correct placement

Actual Results:  
On the initial load and display, the top DIV contains an image of unknown size.
 The vertical size of the DIV is calculated on an assumed image size.  The
following (left most) DIV is placed just under this location.  Then the image
finishes loading.  The top DIV resizes, and the other following DIVs are placed
below this new size.  The left-most following DIV is not moved to the new
location based on the size of the TOP div.

On the re-load, the left-most following DIV gets moved to be under the (now
correctly sized) top DIV where it belongs.

Expected Results:  
Recalculate placement (of already placed items) if a prerequisite item changes
size because of an image load.

This displays correctly in IExplorer, Opera.

This bug exists in all Gecko variants I've tried :: NetScape 7.1, Mozilla 1.7,
FireFox 0.9.

Tested on Win2K as well as XP.

Comment 1

14 years ago
This sounds like bug 242159.
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: firefox.general → core.layout
Version: unspecified → Trunk

Comment 2

14 years ago
Created attachment 163156 [details]
testcase

When you get it down to a minimal testcase, it's identical to the one in bug
242159.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 242159 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
No longer depends on: 242159
Keywords: testcase
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.