[RFE] Install extensions via webpage in the message pane

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: jaap, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8

Installing extensions in thunderbird is less convenient then in ff.
Now you have to click on Get New Extension. Then ff opens then you need to
download the file. Then open it in in the TB extension manager. Close TB. Start TB.

I propose to just open the update.mozilla.org page in the message pane and if
you then clicking on the install link then simply installs the extension

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
I propose using a protocol.  aim has aim://goim?screenname=name (something like
that), so why not tbird://extension/http://update.mozilla.org/file.xpi (for
simplicity).  This would make tbird pop open the "Install extension from site"
window.

Confirming RFE.  Switching OS to all (because on windows this is where AIM does
that, and still it'd be nice to do your easy method too on win), and hardware to
all (because mac users like easy to install extensions too).

CCing myself.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 2

12 years ago
(In reply to comment #0)
> I propose to just open the update.mozilla.org page in the message pane and if
> you then clicking on the install link then simply installs the extension

Parts of AMO require registration/login, which should happen in the browser.
QA Contact: general

Updated

10 years ago
Assignee: mscott → nobody
If I understand this bug correctly, it is fixed in Thunderbird 5, due to the new Add-ons manager which opens in its own Thunderbird tab, and allows users to install extensions from the Add-ons manager.

I guess you could even consider this fixed before then, since a "Get Add-ons" tab was added to the old Add-ons Manager.

Is there anything left for this bug to still be open?
After one week, no-one answered my previous comment, so closing this as WFM.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.