Shift-reload does not really reload

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: info, Assigned: darin.moz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

60.99 KB, application/x-zip-compressed
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

when I Shift-reload a web page, it is not really reloaded sometimes. BTW, I am
using an intranet proxy server.

Reproducible: Sometimes
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
-> Networking
Assignee: general → darin
Component: Browser-General → Networking
QA Contact: general → benc
(Assignee)

Comment 2

15 years ago
Can you please supply a HTTP log per instructions here:

http://www.mozilla.org/projects/netlib/http/http-debugging.html

Thanks!

I suspect a bug in your proxy server.
(Reporter)

Comment 3

15 years ago
Okay, this proxy thing is about Squid, (Debian) version is 2.4.6-2woody2.

Hmm, I see many TCP_CLIENT_REFRESH_MISS which is, I guess, the sign that the
proxy is really re-loading the page. But I see also several TCP_IMS_HIT and TCP_HIT.
(Reporter)

Comment 4

15 years ago
Created attachment 151899 [details]
HTTP session log file

sorry, forgot the log
(Assignee)

Comment 5

15 years ago
here's mozilla's request when you press shift-reload:

0[233e70]: http request [
0[233e70]:   GET http://www.heise.de/stil/standard.css HTTP/1.1
0[233e70]:   Host: www.heise.de
0[233e70]:   User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040616
0[233e70]:   Accept: text/css,*/*;q=0.1
0[233e70]:   Accept-Language: de,en;q=0.5
0[233e70]:   Accept-Encoding: gzip,deflate
0[233e70]:   Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
0[233e70]:   Keep-Alive: 300
0[233e70]:   Proxy-Connection: keep-alive
0[233e70]:   Referer: http://www.heise.de/
0[233e70]:   Pragma: no-cache
0[233e70]:   Cache-Control: no-cache
0[233e70]: ]

and here's the response:

1016[ee2088]: http response [
1016[ee2088]:   HTTP/1.0 200 OK
1016[ee2088]:   Date: Mon, 28 Jun 2004 21:52:53 GMT
1016[ee2088]:   Server: Apache/1.3.29
1016[ee2088]:   Last-Modified: Fri, 04 Jun 2004 23:32:28 GMT
1016[ee2088]:   Etag: "168bfd-10af-40c1068c"
1016[ee2088]:   Accept-Ranges: bytes
1016[ee2088]:   Content-Length: 4271
1016[ee2088]:   Content-Type: text/css
1016[ee2088]:   X-Cache: MISS from wally.zaplinski
1016[ee2088]:   X-Cache-Lookup: HIT from wally.zaplinski:3128
1016[ee2088]:   Proxy-Connection: keep-alive
1016[ee2088]: ]

notice the X-Cache-Lookup header.  i'm not sure exactly what that means, but
there is some documentation on it here:

http://www.squid-cache.org/Doc/FAQ/FAQ-16.html (Section 16.13)

I don't see how this is a bug in Mozilla since we are correctly generating
Pragma: no-cache and Cache-control: no-cache headers.  I think the proxy servers
are misconfigured.

marking INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.