SOAP array doesn't support only one dimension with unumbered item

RESOLVED DUPLICATE of bug 243904

Status

Core Graveyard
Web Services
RESOLVED DUPLICATE of bug 243904
14 years ago
3 months ago

People

(Reporter: Cédric Chantepie, Unassigned)

Tracking

({crash})

Trunk
All
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040623 Firefox/0.9.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040623 Firefox/0.9.0+

When SOAP array contains only one dimension whose items are not numbered
(without "position" attribute), it doesn't initialize correctly result array and
can cause malloc_zone_malloc

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 151869 [details] [diff] [review]
Patch
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Keywords: crash
Resolution: --- → FIXED
(Reporter)

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 241157 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Hardware: Macintosh → All
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 243904 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE

Updated

3 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.