Middle clicking on a bookmarks toolbar folder should append tabs, not replace

RESOLVED DUPLICATE of bug 241305

Status

()

--
minor
RESOLVED DUPLICATE of bug 241305
15 years ago
13 years ago

People

(Reporter: tunah.bugzilla, Assigned: p_ch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040624 Firefox/0.9.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040624 Firefox/0.9.0

Middle clicking on a bookmark folder in the toolbar or bookmarks menu replaces
the current tab set with the folder's contents. This is inconsistent with
behaviour of middle clicking on a bookmark in the toolbar (opens a new tab), and
it causes the user to unexpectedly lose all open tabs. (Dataloss? I'm not
experienced with bugzilla).
One solution is for browser.tabs.loadFolderAndReplace should default to false,
but this causes the "open in tabs" option to also cause appending rather than
replacement. IMO:
*left* clicking "open in tabs" should replace the current tab set, just as left
clicking on a bookmark replaces the current tab.
*middle* clicking on "open in tabs" or the folder itself should append to the
current tab set, just as middle clicking on a bookmark appends a new tab.

Reproducible: Always
Steps to Reproduce:
1. Open several tabs
2. Middle click a bookmark folder
Actual Results:  
All open tabs replaced.

Expected Results:  
Each bookmark in folder opened in a new tab.

*** This bug has been marked as a duplicate of 241305 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
oh, hrm, this is slightly different from that, but its still a WONTFIX since it
introduces inconsistent behaviour with open in tabs (depending on means of
invocation).
*** Bug 320408 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.