File Bookmark dialog form too small, buttons are not visible

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: Stefan_Lange_KA, Assigned: ajschult784)

Tracking

({regression})

Trunk
regression
Bug Flags:
blocking1.8b -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8a2) Gecko/20040627
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8a2) Gecko/20040627

File Bookmark dialogs form height is too small to show bookmark tree completely,
buttons below the tree are not visible.
This only appears on WindowsXP. On Windows98SE the File Bookmark dialog is shown
correctly. 

Reproducible: Always
Steps to Reproduce:
1. any url opened
2. Bookmarks/File Bookmark -> File Bookmark dialog appears, but the form height
is too small: the tree window is not completely visible, buttons are not visible
3. buttons appear, when form height is increased



Expected Results:  
The File Bookmark dialog should all elements: bookmark tree and buttons.

Only on WindowsXP system, not on Windows98SE system

Comment 1

15 years ago
I can confirm this bug on 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040726 Mnenhy/0.6.0.100.
So the bug should be changed from "Windows XP" to "All" in the "OS" settings
(I'm not able to do it.)

But it's present since at least about a month.

Comment 2

15 years ago
Created attachment 154351 [details]
Screenshot on Linux

Comment 3

15 years ago
Does Mozilla saves the window size if you resize it manually? For me it is WFM
on WinNT4.

Comment 4

15 years ago
(In reply to comment #3)
> Does Mozilla saves the window size if you resize it manually?
No.

Comment 5

15 years ago
Confirm this bug on Mac: All Mozilla Seamonkey builds up to nightly 2004082008,
1.8a3 on Mac OSX 10.3.5 (and earlier). Every time File Bookmark is chosen I have
to resize the dialog to find the proper folder and see the response buttons. No
persistence whatsoever, even in the same browsing session. 

(Also, scrolling doesn't work in this dialog, but that's a separate issue.)

Comment 6

15 years ago
(In reply to comment #5)
> (Also, scrolling doesn't work in this dialog, but that's a separate issue.)
BTW: I *am* able to scroll, so it's definitively another issue.

Comment 7

15 years ago
Drat - sorry. I meant, am unable to scroll in this dialog using the scroll
wheel. Using the UI arrows (once the window is large enough to show them)
scrolls fine.

Comment 8

15 years ago
(In reply to comment #7)
> Drat - sorry. I meant, am unable to scroll in this dialog using the scroll
> wheel. Using the UI arrows (once the window is large enough to show them)
> scrolls fine.
For me scrolling is ok with scroll wheel and moving the scrollbar (both when
file dialog is small at the beginning and when rezizing).
(Reporter)

Comment 9

14 years ago
Bug is still present on latest Nightly: Mozilla/5.0 (Windows; U; Windows NT 5.1;
de-AT; rv:1.8a5) Gecko/20041014! 
Product: Browser → Seamonkey
(Reporter)

Comment 10

14 years ago
Bug is still present on latest Nightly: Mozilla 1.8a6
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8a6) Gecko/20041128! Is'nt
there anybody who can fix this bug?

Comment 11

14 years ago
*** Bug 255989 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
*** Bug 256432 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
JFYI: (On Linux) the bug appears on both gtk and gtk2.

Comment 14

14 years ago
*** Bug 278419 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
Confirming, Platform/OS -> All

WFM when creating a new profile, so removing localstore.rdf might help (although
a user shouldn't have to do that, as Akkana already mentioned in bug 278419).
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 16

14 years ago
Requesting blocking status for 1.8b, since duplicate bug 278419 was requesting
it and this is one of those "makes mozilla look really dumb and hard to use"
regressions.
Flags: blocking1.8b?
Keywords: regression
too late for b1, +ing for b2
Flags: blocking1.8b?
Flags: blocking1.8b2+
Flags: blocking1.8b-
(Assignee)

Comment 18

14 years ago
does anybody know how to cause this to happen with a profile that doesn't
exhibit the problem?

if deleting localstore.rdf fixes the bug, can someone attach their ((g)zipped)
localstore.rdf?
(Assignee)

Comment 19

14 years ago
ok Stefan sent me his localstore.rdf, which included:
<RDF:Description
RDF:about="chrome://communicator/content/bookmarks/addBookmark.xul#newBookmarkDialog"
        width="429" height="266" screenX="461" screenY="253" />

current addBookmark.xul does not persist the dialog's width and height (it
persists the width/height of the bookmark tree), so that's why resizing the
dialog doesn't get saved.  I guess the residual width/height is from using
earlier build (before bug 123207, it did persist the dialog's size).

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpfe/components/bookmarks/resources/addBookmark.xul&mark=61,115
URL: all
(Assignee)

Comment 21

14 years ago
Warning: reference to undefined property bookmarkView.view
Source File: chrome://communicator/content/bookmarks/addBookmark.js
Line: 179

Error: bookmarkView.view has no properties
Source File: chrome://communicator/content/bookmarks/addBookmark.js
Line: 179
(Assignee)

Comment 22

14 years ago
Created attachment 178043 [details] [diff] [review]
bookmarkView.view -> bookmarkView.tree.view

this is bustage from bug 221619
Assignee: p_ch → ajschult
Status: NEW → ASSIGNED
Attachment #178043 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #178043 - Flags: review?(neil.parkwaycc.co.uk)
Comment on attachment 178043 [details] [diff] [review]
bookmarkView.view -> bookmarkView.tree.view

Turns out I had this patch sitting in my tree for some time (although that
version used treeBoxObject.view), probably for reviewing another bookmarks bug.
Attachment #178043 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #178043 - Flags: superreview+
Attachment #178043 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #178043 - Flags: review+
(Assignee)

Comment 24

14 years ago
FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.