Closed Bug 248982 Opened 18 years ago Closed 18 years ago

"Tell your Friends" feature under Help menu

Categories

(Firefox :: General, defect, P4)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: bugzilla)

References

Details

(Keywords: fixed-aviary1.0)

 
Flags: blocking-aviary1.0+
Priority: -- → P2
OS: Windows XP → All
Hardware: PC → All
Flags: blocking-aviary1.0RC1+
out of curiosity, what would this menu item do? would it send the user to a page
with a form (to fill out with friends' email, etc.)? or would it open a mail
compose window (with the default mail app)?
I think page with a form is better, it takes all the guesswork out of getting it
to work correctly.

We need to have a good privacy policy that states we don't retain data, will
never spam people, etc...
I don't know what's proposed, but policies aside, if this is going to use email
then it has to actively prevent people from abusing it. With a web form, that
job is made harder, because it means the server has to generate and send the
email on behalf of the user without knowing anything about who they are. Web
forms that email to and from third parties are generally a pain to handle.

If it could be arranged for the email to come from the user's usual email
client, that saves a whole load of trouble and the email can come direct from
their address, rather than having to come from a mozilla.org server and address...
Flags: blocking-aviary1.0RC1+
Priority: P2 → P4
Putting back on the PR radar since this work is finished.
Flags: blocking-aviary1.0PR+
Fix checked in. The pages themselves are not yet in the proper locations. The
content is ready, we just aren't going to push them live until PR1 launch.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Please consider internationalisation and localisation, when you add such items
to Firefox. 
blake, the address is stored in a dtd file, right?
Add a comment "under construction" in http://www.spreadfirefox.com/ please.
It'll make sure people won't start to file bugs for it !
(In reply to comment #7)
> blake, the address is stored in a dtd file, right?
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=AVIARY_1_0_20040515_BRANCH&branchtype=match&dir=&file=&filetype=match&who=blakeross%25telocity.com&whotype=match&sortby=Date&hours=2&date=explicit&mindate=08%2F02%2F2004&maxdate=08%2F03%2F2004&cvsroot=%2Fcvsroot
Shows the files changed, browser.dtd, region.properties, brand.dtd are localized
changes.


Also, was the part of this patch getting rid of Release Notes intended?
Keywords: fixed-aviary1.0
*** Bug 255278 has been marked as a duplicate of this bug. ***
*** Bug 255278 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.