CSS text-decoration: underline is computed correctly for table captions, but not displayed

VERIFIED DUPLICATE of bug 202930

Status

()

VERIFIED DUPLICATE of bug 202930
15 years ago
13 years ago

People

(Reporter: bugmail, Unassigned)

Tracking

({css1, testcase})

Trunk
x86
Windows NT
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
When a CSS text-decoration rule is used to apply underline to a table caption
element, the style is computed correctly but no underline is drawn.

In the attached testcase, note that the bold and underline styles are both
applied to the text paragraph, but only the bold rule is applied to the caption.
Examining the caption using the DOM Inspector reveals the text-decoration
computed style to be underline, but no underline is drawn.
(Reporter)

Comment 1

15 years ago
Created attachment 151931 [details]
HTML Testcase

Note that I observed this problem using both Windows Firefox 0.9.1 and Mozilla
1.7. (I believe I also observed this using Mac Camino 0.8, but didn't have time
to really verify it.)
(Reporter)

Updated

15 years ago
Keywords: testcase
Well, the testcase works for me using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/2002-12-12

But it doesn't work for me, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/2003-02-10
OS: Windows NT → All
Hardware: PC → All

Comment 3

15 years ago
Dupe of 202930 via bug 213867

*** This bug has been marked as a duplicate of 202930 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
OS: All → Windows NT
Hardware: All → PC
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.