Recurrence: Repeat every: Number of Times

RESOLVED FIXED

Status

Calendar
Sunbird Only
--
minor
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: jason lowry, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

In the Recurrence Rules, if you select "Repeat Every" then you are able to
select the radio buttons for how long the recurrence will run. If you select
"Number of times:" then it defaults to 0. By increasing the value to 1, you
would assume that this meant "Repeat Once the following day/week/month".
Increasing to 2 would be "repeat twice" or three total events.

However, 0 & 1 have the same functionality. So in my mind, the logic is broken.
Either the default value should be 1 (not 0) or selecting 1 should mean "Repeat
Once (Plus the original)"

Reproducible: Always
Steps to Reproduce:
1. Add a new event
2. Select the recurrence tab
3. Check Repeat Every
4. Select the "Number of times"
5. Increase the value to 1

Actual Results:  
Notice that the event doesn't get repeated? 

Expected Results:  
The "number of times" either needs to default to 1 (meaning total number of
times the event will occur) or needs to default to 0 with 1 adding an occurance
(meaning the total time the event will reoccur).

Comment 1

14 years ago
*** Bug 249076 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Created attachment 152344 [details] [diff] [review]
eventDialog.js, todoDialog.js patch recurCount: 0 if not selected, min 1 if selected

Confirm.

Design:  Minimum displayed value is 1.	If not selected, stored value is 0.  If
selected, minimum stored value is 1.  

(Another problem occurred if a non-zero value is entered but the radio button
was not selected: the value was stored, so when it was opened again the radio
became selected in addition to the originally selected radio button, so
multiple radio buttons were selected.  Fix explicitly stores 0 if not selected,
and never stores 0 if it is selected.)

patch details:

eventDialog.js
 loadCalendarEventDialog: setFieldValue repeat-numberOfTimes-text to at least 1

 onOKCommand:  if repeatNumberOfTimes-radio is selected store value at least 1
  if not selected, always set to 0.
  Also add declaration for var i used in loops (strict javascript warning)

todoDialog.js
  ditto
(Assignee)

Comment 3

14 years ago
Patch checked in. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.