sunbird doesn't work with the extension manager

RESOLVED FIXED

Status

Calendar
General
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Michiel van Leeuwen (email: mvl+moz@), Assigned: Michiel van Leeuwen (email: mvl+moz@))

Tracking

Details

Attachments

(1 attachment)

Sunbird doesn't start due to the extension manager. I've seen it going into an
infinite restart loop.
Two solutions: fix the extension manager or disable it. It doesn't look like it
will be fixed, and given that sunbird doesn't have a use for it, i want to
disable it.
(Assignee)

Comment 1

14 years ago
Created attachment 151959 [details] [diff] [review]
disable it

There is no configure option or anything, so i just hacked some ifdefs into
apprunner.
(apps should really be able to opt out from the extension manager....)
(Assignee)

Updated

14 years ago
Attachment #151959 - Flags: first-review?(bsmedberg)

Comment 2

14 years ago
Comment on attachment 151959 [details] [diff] [review]
disable it

1) Using #ifdefs is not acceptable. If you must do configuration like this,
please add a boolean flag to the nsXULAppAPI structure.

2) I *strongly* encourage you to use the extension manager. You will probably
want it for theme and langpack management. Does your app have the basic
required UID and version set in prefs? I would prefer to fix the EM rather than
paper over the problems.
Attachment #151959 - Flags: first-review?(bsmedberg) → first-review-
(Assignee)

Comment 3

14 years ago
Is there some documentation that describes what is needed to make extension
manager work? i tried to reverse engineer the checkins, but couldn't figure it out.
(Assignee)

Comment 4

14 years ago
This patch is just to get sunbird running again. I don't see any movement in
making the extension manager work for sunbird. I don't like to touch all
standalone apps now. I just want sunbird working again. The real fix can come later.

Comment 5

14 years ago
I agree bsmedberg

We (at least I) *want* EM in Sunbird, especially in the future, since I will be
doing some additions to calendar which will allow calendar specific extensions
to come, (no talk on them yet until they are done and mostafah approves).  Since
it is stuff that Cal could really use but imo shouldnt be in by default.

Though right now all we need is Sunbird _running_ once that is done the needed
EM fixes to get it to be enabled/disabled by choice for each *app* can come later.

With mine and Wolf's comments I will request review once more

Updated

14 years ago
Attachment #151959 - Flags: first-review- → first-review?(bsmedberg)

Comment 6

14 years ago
Running "make sunbird" in mozilla/calendar/sunbird is a good way to make sure
all the files needed to run sunbird have been built and are present. I've
updated the makefile to check for the files needed for extension manager support.
When I build sunbird the old way, that is by including browser/config/mozconfig
and --enable-calendar, I get all the files. If building sunbird with the new
instructions does not produce the list of files needed, we should update our
mozconfig and/or instructions.
(Assignee)

Comment 7

14 years ago
The problem is in some magic combination of needed files, needed prefs and maybe
other stuff. As long as we don't know which combination, i'd like sunbird to
still work.

Comment 8

14 years ago
This check-in adds extension manager support to sunbird and the build eventually
runs:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fcalendar%2Fsunbird%2Fapp&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-07-02+7%3A45&maxdate=2004-07-02+8%3A10&cvsroot=%2Fcvsroot

Note that sunbird's app uid is:

718e30fb-e89b-41dd-9da7-e25a45638b28

the theme uid is:

8af2d0a7-e394-4de2-ae55-2dae532a7a9b

and there is one extension uid available which originally was for inspector:

056555d3-e0e0-408f-9b89-8a0189c7bc63

(It's empty now )

With this sunbird should be alive again and tweaks can be made to these
extensions to make them work properly.

Can somebody else give it a try too?

Comment 9

14 years ago
Comment on attachment 151959 [details] [diff] [review]
disable it

Is this bug resolved, now?
Attachment #151959 - Flags: first-review?(bsmedberg) → first-review-

Comment 10

14 years ago
Is the Extension Manager is going to be exposed, so we can start writing Sunbird
extensions?

Comment 11

14 years ago
This bug is resolved.
David: Extension support for sunbird is being tracked in bug 115226.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.