Double-clicking on partially visible row in Open/Save Dialogs opens wrong item

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Brian Kerley, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040617 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040617 Firefox/0.9

The open and save dialog boxes are just a little too small.  Currently, they
show 8 folders at a time.  The problem is, if you select the bottom folder, the
slider moves down a little because the bottom folder is not entirely "in" the
window.  So, if you try to double click on that bottom folder, you end up
opening the wrong folder.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
The scrollbar slides down and causes the wrong folder to open when you double click.

Expected Results:  
The bottom folder should be double-clickable

It should be a simple matter to just have the window drawn an extra few pixels
larger than it currently is, so that the bottom folder is double clickable
(Reporter)

Updated

14 years ago
Component: File Handling → General
This is fixed in seamonkey trunk (bug 130477). Bug still occurs in seamonkey 1.7
release, firefox current aviary and trunk. I doubt tweaking the dialog size
could fix this reliably (fx themes, gtk themes, font settings).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Open/Save Dialogs are just a little too small → Double-clicking on partially visible row in Open/Save Dialogs opens wrong item

Comment 2

14 years ago
Created attachment 157163 [details]
Screen shot showing modal dialog that won't go away.
Fixed, long ago and in the most twisted way possible, by bug 250306.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.