reply to all, remove some (but not all) recipients, send results in "please specify a recipient"

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Chris Petersen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510 Galeon/1.3.15
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510 Galeon/1.3.15

thunderbird 0.7.1 binary from mozilla.org

I just tried to reply to a mailing list message.  I hit reply-to-all (since
tbird doesn't have a "reply to list" command -- hint, hint), and since I didn't
need to send a copy to the sender (he's already on the list) or the person he
cc'd (likewise), I removed those names, and changed the list address from a Cc
field to a To field.  I then typed my message and tried to send it, but was
given a "this message has no recipients" type error.

Reproducible: Always
Steps to Reproduce:
1. Find a message with several recipients
2. reply to all
3. Pick one of the recipients that shows up as "cc" and change to "to"
4. Delete all of the other recipients
5. try to send the message.

Actual Results:  
error saying that I need to add a recipient to the message

Expected Results:  
Message should send - it clearly has a recipient.

Comment 1

14 years ago
Created attachment 160707 [details]
screen shot of error messages

Comment 2

14 years ago
This same bug exists in the Windows Thunderbird 0.8 binary, and occurs about 1
in 4 times when replying to mailing lists.

Another side effect is that the drop down box with potential return
addresses/accounts becomes "pollluted" with extra copies of all accounts.

I never saw this bug when running 0.7.1 or 0.5, but it clearly exists.

Comment 3

14 years ago
Does this problem happen repeatedly on the same message?
(Reporter)

Comment 4

14 years ago
This appears to work fine for me now in 1.0
(Assignee)

Comment 5

14 years ago
per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.