Wrong numbering of duplicate downloads

RESOLVED DUPLICATE of bug 231048

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 231048
14 years ago
10 years ago

People

(Reporter: Dmitry Ivanov, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

When I download atlassian-jira-professional-2.6.1-standalone-tomcat.tar.gz it is
saved as atlassian-jira-professional-2.6.1-standalone-tomcat.tar.gz. When I
download it again it is saved as
atlassian-jira-professional-3.6.1-standalone-tomcat.tar.gz

The same happens with libwrap0-dev_7.6-4.ipv6.r2_i386.deb and any files with
similar names.


Reproducible: Always
Steps to Reproduce:
1. Go to any software repository which contains files with version names
2. Download one such file twice

Actual Results:  
File is saved as two files with different names like this:

libwrap0-dev_7.6-4.ipv6.r2_i386.deb
libwrap0-dev_8.6-4.ipv6.r2_i386.deb


Expected Results:  
It should save it as two files with names like:

libwrap0-dev_7.6-4.ipv6.r2_i386.deb
libwrap0-dev_7.6-4.ipv6.r2_i386.deb.2

or

libwrap0-dev_7.6-4.ipv6.r2_i386.deb
libwrap0-dev_7.6-4.ipv6.r2_i386.2.deb

without changing digits in the middle of filename

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.