Multiple CSS files will not be loaded (fully)

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Stephan Haller, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

By migrating to Firefox 0.9.1 and checking our homepage (still in development) I
recognize missing CSS styles on many elements like body, table rows or cells and
so on. Everytime the main site displaying the news will be loaded and displayed
properly. But as soon as I switch to another page within this site (either via
menu at the left or by entering the URL into the location bar) it starts to miss
out some CSS styles. If you press reload it will show some CSS style missing at
the first time but it also starts to miss some others.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.froevel.de/~nomad.froevel.de/ (It's german. Sorry!)
2. Now start to move between the pages via the menu at the left
3. Mostly the first thing what happens is that the background (body) turns from
gray to white.

Actual Results:  
Some CSS style are missed out! Mostly it begins with turning the background of
the body from gray to white but continues with font size/style/family.

Expected Results:  
It should work as in Firefox 0.8 which I've installed in another directory.
Firefox 0.8 does not miss anything.

Comment 1

14 years ago
WFM 20040629 PC/Win2000
(Reporter)

Comment 2

14 years ago
I have reinstalled Firefox 0.9.1 and reloaded the page mentioned above. After
opening the JavaScript Console for checking some JavaScript errors I produced ;)
I recognized that Firefox means that the css files loaded will not be used
because they have wrong MIME types ('text/plain' instead 'text/css'). That does
not seem to be true.

First because the first it loads the page everything is okay. Second if I load
in the CSS file directly into Firefox and call up the page info dialog Firefox
tells me it is a 'text/css'.
Did you try Shift-Reload?  Maybe they used to have the wrong mime type but
they're now cached.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

14 years ago
Now it is getting funny!

Okay here comes what I did step by step:

1. Launch Firefox-0.9.1
2. Cleared the cache
3. Calling http://www.froevel.de/~nomad.froevel.de/
4. Page loaded and displayed properly
5. Press the reload button
6. Page loaded but body element has now white background instead of a grey one
7. Pressed reload again
8. Page's body background still white
9. Did pressed SHIFT and reload button simultaneously
10. Page loaded and displayed properly
11. Press the reload button
12. Page loaded but body element has now white background instead of a grey one
13. Did pressed SHIFT and reload button simultaneously
14. Page loaded and displayed properly
15. Did pressed SHIFT and reload button simultaneously
16. Page loaded and displayed properly

If I reload the page the background turn white which is the first evidence for
CSS not loaded. As long as I do not clear the cache or do a "SHIFT-Reload" the
CSS will not load properly although if loaded directly it is declared as
'text/css' either from cache or not.

So I reopen the bug even if "SHIFT-Reload" works. Maybe CSS files are not cached
properly?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Still worksforme.  Are you using an HTTP proxy?  (transparent?)
Assignee: dbaron → darin
Component: Style System (CSS) → Networking
QA Contact: ian → benc
(Reporter)

Comment 6

14 years ago
No I'm using a direct internet connection without any proxy, firewall or other
"disturbing" services. Not even a router.
(Assignee)

Comment 7

14 years ago
please provide a mozilla http log, per these instructions:

  http://www.mozilla.org/projects/netlib/http/http-debugging.html

thanks!
(Reporter)

Comment 8

14 years ago
Okay I did create a http log as told ;)

What I did whiele creating the log file:

1. Requested http://www.froevel.de/~nomad.froevel.de/
2. Waited for Firefox saying that all datas are loaded
3. Pressed 'Refresh' button, saw background turning white and waited again for
Firefox being ready
4. Did step 3 again
5. Closed Firefox and stopped logging

The log file is really big. Somthing about 2MB. I took the the options (env.
vars) as provided on the debug page.
(Reporter)

Comment 9

14 years ago
Created attachment 152763 [details]
HTTP log file for CSS problem at http://www.froevel.de/~nomad.froevel.de at 10.06.2004  14:50

Part 1 of 10
(Reporter)

Comment 10

14 years ago
Created attachment 152765 [details]
HTTP log file for CSS problem at http://www.froevel.de/~nomad.froevel.de at 10.06.2004  14:50

Part 2 of 10
(Reporter)

Comment 11

14 years ago
Created attachment 152766 [details]
HTTP log file for CSS problem at http://www.froevel.de/~nomad.froevel.de at 10.06.2004  14:50

Part 3 of 10
(Reporter)

Comment 12

14 years ago
Created attachment 152767 [details]
HTTP log file for CSS problem at http://www.froevel.de/~nomad.froevel.de at 10.06.2004  14:50

Part 4 of 10
(Reporter)

Comment 13

14 years ago
Created attachment 152768 [details]
HTTP log file for CSS problem at http://www.froevel.de/~nomad.froevel.de at 10.06.2004  14:50

Part 5 of 10
(Reporter)

Comment 14

14 years ago
Created attachment 152769 [details]
HTTP log file for CSS problem at http://www.froevel.de/~nomad.froevel.de at 10.06.2004  14:50

Part 6 of 10
(Reporter)

Comment 15

14 years ago
Created attachment 152770 [details]
HTTP log file for CSS problem at http://www.froevel.de/~nomad.froevel.de at 10.06.2004 14:50

Sorry I forgot to compress :D **errmmm***
(Assignee)

Comment 16

14 years ago
WORKSFORME... log file indicates that all URIs were loaded correctly from a
networking point of view.

reporter: can you please test with a new firefox profile?  run 'firefox -P' to
create and use a new profile.
(Reporter)

Comment 17

14 years ago
Thanks for help!!!

After creating a new profile everything works as expected. So I dediced to
delete the whole .mozilla directory in my home directory. Started Firefox again
and was asked to import my old Firefox 0.8 profile or do nothing. First I
decided to do nothing. Then I loaded the page, refreshed it and ..... :)==) All
was working!

Then I deleted the .mozilla folder again. Started Firefox again and told it to
import my 0.8 profile. And again all is working!!!!

But the question is why didn't it work the first time even with cache cleared.
May it be because the working profile for 0.9.1 was a previous 0.9?

Questions over questions?

But thanks to you all!!!!! Now I can start loving 0.9.1 again :D

Closing bug as fixed!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
nothing changed in Mozilla = not fixed
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
-> worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 20

14 years ago
Ahhh ... okay! Seems there are some things to learn ;)
You need to log in before you can comment on or make changes to this bug.