kibrisgazetesi.com - the hyperlinks do not work.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: zorba_o, Unassigned)

Tracking

Details

(Whiteboard: [havefix], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8

When the perl based web site is accessed the home page appears to be fine.
However, when the hyperlink is hovered over a single page with the link text
appear. This problem exists with Mozilla 1.6 as well and is not present with
Opera or IE.

Reproducible: Always
Steps to Reproduce:
1. Go to the site and try to hver over a link.
2.
3.

Updated

15 years ago
Assignee: bugs → general
Component: Web Site → Browser-General
Product: Firefox → Browser
QA Contact: general
Version: unspecified → Trunk

Comment 1

15 years ago
-->TE
the problem is this code here in line 594:
    if (navigator.appName=='Netscape') {document.write(unescape(newText));
document.close();}
this also catches Mozilla and Netscape 6/7, but this code was written for
Netscape 4. As far as i see this 
if (navigator.appName=='Netscape')
needs to be replaced with 
if (document.layers)
because Mozilla/N6/N7 supports the innerHTML method in line 595. 
Someone needs to find out a contact adress and write a mail to them (prefered in
Turkish language) and point them to the fix..
Status: UNCONFIRMED → NEW
Component: Browser-General → Other
Ever confirmed: true
Product: Browser → Tech Evangelism
Whiteboard: [havefix]
Version: Trunk → unspecified

Updated

14 years ago
Assignee: general → other
QA Contact: general → other
Summary: the hyperlinks do not work. → kibrisgazetesi.com - the hyperlinks do not work.

Comment 2

9 years ago
No apparent issues with site, don't see the code referenced in comment #1.

Tested in FF3.6/3.5/3
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.