Making FFox 0.9+ default browser does not properly set DDE for file types

VERIFIED DUPLICATE of bug 246078

Status

()

Firefox
File Handling
--
major
VERIFIED DUPLICATE of bug 246078
14 years ago
14 years ago

People

(Reporter: Don Feliciano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Windows file associations for URL: are updated to use FireFox, but DDE settings
remain set to Internet Explorer.  Result is an error dialog stating that the
"application cannot be found", and a new FFox browser window.  This is a
regressive defect, as it works in FireFox 0.8 as expected.  Work-around is to
manually adjust DDE parameters for URL: file handlers.

Have reproduced on Windows 2003 and Windows XP.

Reproducible: Always
Steps to Reproduce:
1.  Make IE your default browser
2.  Install FireFox 0.9+
3.  Make FireFox your default browser
4.  Start > Run > http://mozilla.org/

Actual Results:  
FireFox launched and opened http://mozilla.org/, but a Windows error dialog also
appeared stating that the requested appication could not be found.

Expected Results:  
Should not get error dialog

There is a manual work-around.  Change the DDE settings for all URL: file types

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Component: File Handling → File Handling
Product: Browser → Firefox
QA Contact: ian → bmo
Version: Trunk → unspecified

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.