incorrectly renders W3C xhtml 1.0/CSS validated pages

RESOLVED INVALID

Status

()

--
blocker
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: breakspearc, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

This is the second time today I've written a valid page, but it doesn't render
correctly.  It seems like FF cannot consistently find the CSS.  When it does, it
puts the http headers at the top of the page.  I have the web developer
extension installed, and it says that the browser is running in quirks mode, but
it shouldn't be, and it wasn't earlier.

Reproducible: Always
Steps to Reproduce:
1. Load the page.
2. Hit refresh several times.
3. Sometimes you get CSS, sometimes you don't.

Actual Results:  
Sometimes you get boxes, sometimes you just get plain text.  When you do get
boxes, you get http headers in plain text.

Expected Results:  
Always see boxes, never headers.

Nothing special...  The pages loads perfectly in IE 6.0 every time.  I'm rating
this as a blocker because rendering the pages incorrectly or unreliably is
pretty serious in my books.

Comment 1

14 years ago
Error: The stylesheet http://chatt.hdsb.ca/~breakspearc/exp/style.css was not
loaded because its MIME type, "text/html", is not "text/css".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.