Setting Mozilla Mail as default mail application does not work correctly

RESOLVED DUPLICATE of bug 202497

Status

RESOLVED DUPLICATE of bug 202497
14 years ago
10 years ago

People

(Reporter: hjtoi-bugzilla, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

When I set Mozilla Mail as default mail application (Mozilla 1.7), I can right
click a file in Windows Explorer and that will launch Mozilla Mail to send it.

However, when I try File > Send Page... using Firefox 0.9.1, Firefox will launch
Outlook. I first filed this as bug 249311, but then realized it is not a Firefox
bug but rather a bug in how Mozilla Mail sets the default mail application for
Windows.

When I look at Control Panel > Internet Options > Programs Tab > E-Mail
Drop-down, I see that the default is Outlook. I would have expected Mozilla
Mail, since I have that preference set in Mozilla Mail, and also because
right-click, send works from Windows Explorer.

Once I set Control Panel > Internet Options > Programs Tab > E-Mail Drop-down to
Mozilla Mail, Firefox will launch Mozilla Mail to send mail.

Therefore I would expect that when the Use Mozilla Mail as the default mail
application preference is set, it would also set Control Panel > Internet
Options > Programs Tab > E-Mail Drop-down as Mozilla Mail.

Comment 1

14 years ago
dup of bug 202497?
Seems like it is indeed a dupe, thanks.

*** This bug has been marked as a duplicate of 202497 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.