CTRL+TAB does not move betweeen tabs correctly

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Ben Knight, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When hitting CTRL+TAB, it works fine till after the last Tab after which it
jumps up to the location bar.  At that point, I have to click on the first tab
again in order to start tabbing again.  I like to circle through tabbed windows
when comparison shopping, for example.

Reproducible: Always
Steps to Reproduce:
1. Open a bunch of tabs
2. Try CTRL+TAB

Comment 1

14 years ago
We really need a Firefox "Keyboard: Navigation" component :/  Chris?
Component: Keyboard: Navigation → Tabbed Browser
Product: Browser → Firefox
Version: Trunk → unspecified

Updated

14 years ago
Assignee: aaronleventhal → bugs
QA Contact: firefox.tabbed-browser

Comment 2

14 years ago
Could not reproduce with: Windows NT 5.0, rv:1.7 Gecko/20040626 Firefox/0.9.1
works for me on 0.9.1 in a normal situation.

note that weird things happen if you open a bunch of blank tabs, but I think
that's and edge case.

Comment 4

14 years ago
Works for me as well. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040624 Firefox/0.9

Comment 5

14 years ago
I realize that this bug was filed for a different problem (which I can't
reproduce, btw), but am I the only one that thinks it's natural for CTRL-TAB to
behave the same was ALT-TAB does in Windows?  That way you can go back and forth
between 2 tabs easily, even if you have more than that open.  Personally, I find
the current behavior pretty useless.  I'll be happy to open another bug if
anyone agrees. . .

Comment 6

14 years ago
(In reply to comment #5)
> I realize that this bug was filed for a different problem (which I can't
> reproduce, btw), but am I the only one that thinks it's natural for CTRL-TAB to
> behave the same was ALT-TAB does in Windows?  That way you can go back and forth
> between 2 tabs easily, even if you have more than that open.  Personally, I find
> the current behavior pretty useless.  I'll be happy to open another bug if
> anyone agrees. . .
You can use Ctrl+PageUp and Ctrl+PageDown to navigate back and forth in the tab
list. The Alt+Tab behaviour in Windows shows you the list of windows in a
separate window, it would be odd if Ctrl+Tab would start jumping from tab to
tab; it would confuse a lot of users in my opinion.

we're not going to change that behaviour.  Without a visual representation,
making it anything more complex than forward/back is seriously going to hurt
usability.

Imagine using Alt-Tab between more than two windows without the window popping
up... it'd get ugly real fast if the order changed based on the order you
accessed them last.

</offtopic>

This is still WFM on branch builds, don't have a trunk handy, can anyone confirm
this?

Comment 8

14 years ago
I can imagine a keystroke for toggling between the most recent 2 tabs. Not sure
what key would be intutive though.

Comment 9

14 years ago

(In reply to comment #7)
> we're not going to change that behaviour.  Without a visual representation,
> making it anything more complex than forward/back is seriously going to hurt
> usability.
> 
> Imagine using Alt-Tab between more than two windows without the window popping
> up... it'd get ugly real fast if the order changed based on the order you
> accessed them last.
> 
> </offtopic>

Good point, I'll admit I hadn't thought about that.  But I still think the
current cycling behavior is pretty useless.  Especially since I think most
people use alt-tab just to switch between 2 programs repeatedly. You could
either add a visual representation ala alt-tab, or actually switch the tabs each
time the user hits ctrl, instead of Windows way of only when you release.
Anyway, just throwing out ideas. 

Comment 10

14 years ago
Should this bug just be closed?  It appears no one can reproduce it. . .
couldn't reproduce
->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.