Feature/ Bug/ Internal w3c Inconsistency (?)

RESOLVED INVALID

Status

()

Core
Layout: Floats
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Leonard Mada, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

I have created some floats, that leave some empty space where NO other
float/content/margin is. The w3c specifications should alow a following block to
get there and indeed Mozilla DOES this (sometimes, depending on construct).

In my float model a following block is split into two pieces, quite nice (in IE
this is NOT the case).

BUT i am NOT sure IF this is correct or a bug or even the w3c specifiacations
are broken in this circumstance.

Don't forget to resize the window and watch for the effects!

Reproducible: Always
Steps to Reproduce:
1. open html file I have appended (download from url)
2. resize browser window
3. watch for green paragraph (it is actually only one <p>...</p>)
4. please download html from the url as I will have to delete it!!!

Actual Results:  
Paragraph is split into two portions containing text. Text wraps from first part
to second part. Quite cool!

Expected Results:  
Could be that even w3c specifications are broken.

I enter it as major bug, because of the above possibility (w3c inconsistency
?)!!! BUT you could regard it as a beutiful feature, too.

Comment 1

14 years ago
Created attachment 152118 [details]
Testcase
Given the markup on that page, our rendering is correct (the 100% width float is
pushed down 50-some pixels by thin floats, since it can't fit next to them, and
text flows into that space, as it should).

I don't see any inconsistencies anywhere here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.