move to trash on delete method does not move messages, copies and marks as deleted, mail invisibly takes up space until expunged

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
--
minor
RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: Mike Moyer, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

Using Mozilla mail in IMAP mode against Sun Inetnet Messaging Server 5.2. 
Option set to move to trash folder on delete.  However, the message is not
MOVEd, it is COPYed to trash, and marked as deleted.  Mozilla will no longer
display the original message.  Using another client (IMP in this case), message
still appears in original mailbox, but marked as deleted.  Still taking up quota
space though.  Obvious fix is to set expunge on exit if you know the problem
exists, also that only does expunge on exit.

Reproducible: Always
Steps to Reproduce:
1.  Set delete option to move to trash
2.  Delete message from IMAP folder
3.  Use another client to view same IMAP folder

Actual Results:  
Message appears, deleted flag set

Expected Results:  
MOVEd the message to the trash folder

Comment 1

14 years ago
Seems invalid - see bug 200786 comment 1
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Seems invalid - see bug 200786 comment 1

Bug 200786 seems to be referring to bloat of the local filesystem mail database.
 I was referring to the effect on the actual IMAP server-side folder.  IMAP
quotas tend to be much more constraining than local filesystems.  However, the
"compact this folder" option does expunge messages marked as deleted in IMAP
folders - if a user knew to do that.  Because these messages marked for deletion
are not seen in Mozilla, IMAP quota utilization may appear to grow without
reasonable explaination, particularly if Mozilla is the sole mail client used.

Comment 3

14 years ago
Maybe this could be solved by the enhancement request in bug 127888?
(Assignee)

Comment 4

14 years ago
invalid. You can already expunge an imap folder by using the context menu in the
folder pane and picking "compact this folder". A toolbar button would make it
easier, yes, but the functionality is already there. Also, if you open a folder
with > 20 deleted messages, we will automatically expunge the folder, so folders
tend to get expunged in the normal course of things.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
Ok maybe the enhancement isn't really needed but I did notice that when I delete
a message, empty the trash and then compact the trash folder, the message still
exists on the server (I have server access to see).  It isn't until I compact
the INBOX folder (trash is a subfolder of INBOX) that the message finally gets
expunged.  Is this a bug?
(Assignee)

Comment 6

14 years ago
you have to compact the folder you deleted the message from, not the trash.

Comment 7

14 years ago
If this is the case, then why does the trash folder have compact this folder in
it's context menu?
(Assignee)

Comment 8

14 years ago
*all* folders have this in their context menu. You can delete messages from the
trash as well, and then compact the trash to remove the deleted but not expunged
messages.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.