thunderbird crashing during search of emails [@ 0x00000000 - nsMsgQuoteListener::Release ]

RESOLVED DUPLICATE of bug 254199

Status

--
critical
RESOLVED DUPLICATE of bug 254199
15 years ago
14 years ago

People

(Reporter: nicolas, Assigned: mscott)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

If one hits "enter" while a search for an email is performed in a folder,
Thunderbird crashes. This happens only while another search is in progress.

Reproducible: Always
Steps to Reproduce:
1. right click on a folder
2. select "search messages"
3. enter search criterias. Hit "Enter" to start the search
4. change the search criterias
5. hit "enter"

Actual Results:  
crash

Expected Results:  
no crash, obviously.

Comment 1

15 years ago
Nicolas Chevreux: Could you provide TalkBack incident ID?
Severity: major → critical
Keywords: crash

Comment 2

15 years ago
This is consistently reproducible with at least Thunderbird 0.5 through 0.7.1

A Talkback incident ID for this is 320552

Comment 3

15 years ago
0x00000000
nsMsgQuoteListener::Release 
[e:/builds/tbird-0.7.1/WINNT_5.0_Clobber/mozilla/mailnews/compose/src/nsMsgQuote.cpp,
line 65]
ole32.dll + 0x4220 (0x77a54220)
ole32.dll + 0x60ad4 (0x77ab0ad4)
Summary: thunderbird crashing during search of emails → thunderbird crashing during search of emails [@ 0x00000000 - nsMsgQuoteListener::Release ]

Comment 4

15 years ago
Created attachment 153101 [details]
Mac OS X Crash Reporter Logs (3 crashes)

Thunderbird version 0.7.1 (20040626); Mac OS 10.2.8

I reproduced this crash three times on my Mac. Talkback only launched on the
third crash. Attaching Mac OS X Crash Reporter logs for the three crashes now,
will provide the Talkback ID when available.

Comment 5

15 years ago
This bug may be a duplicate of Bug 242944.

Comment 6

15 years ago
Talkback ID: TB332649K

Comment 7

15 years ago
The recent fix for bug 251605 does not appear to fix this one.  This is based on
the 2004-07-18-04-0.8 win32 nightly build.

Comment 8

15 years ago
I can no longer repro this with the checkin for bug 254199.  I have tested this
with a 20040808 win32 nightly branch build of Thunderbird.

It is unclear if this bug report is for all types of advanced email searches or
just for advanced email body searches.  If it is the latter, then this is
identical to bug 254199.  FWIW, I haven't been able to see crashes other than
for searches in the body of emails.

Comment 9

14 years ago
Also encountered this bug on win 2000 Sp4 running Thunderbird 0.5 /0.6/0.7.3
(Reporter)

Comment 10

14 years ago
can not reproduce the bug anymore on TB 0.8 Build 20040830, Win XPPro SP1

Comment 11

14 years ago
Reporter :

So, if you cannot reproduce this bug, it should be closed ?

(Reporter)

Comment 12

14 years ago
(In reply to comment #11)
> So, if you cannot reproduce this bug, it should be closed ?

Seems that other people still can reproduce it (see above).

Comment 13

14 years ago
This crash is fixed in the the latest nightlies (0.8 branch builds).  I was able
to crash with 0.7.3, but have not been able to with recent builds.  This looks a
lot like bug 256634 and bug 254199.

Marking dup of bug 254199.

*** This bug has been marked as a duplicate of 254199 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ 0x00000000 - nsMsgQuoteListener::Release ]
You need to log in before you can comment on or make changes to this bug.