textbox in an <input type="file"> does not resize correctly to css width property.

VERIFIED DUPLICATE of bug 52500

Status

()

VERIFIED DUPLICATE of bug 52500
15 years ago
15 years ago

People

(Reporter: dwightb, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.8

The form field input type=file only resizes the container.

When the width is set the textbox should resize to fill the available space. 
This is correctly handled in IE6 and Opera 7.51

Reproducible: Always
Steps to Reproduce:
1. Create a form field like: <input type="file" style="width: 4in;" />

Actual Results:  
Only the container resized to the correct width. This can be verified by
changing the page background color or putting a border around the control.

Expected Results:  
Resize the textbox of the control to fill the available space.
(Reporter)

Updated

15 years ago
Summary: textbox in an <input type="file"> does not resize to css width → textbox in an <input type="file"> does not resize correctly to css width property.

Comment 1

15 years ago
I see this too.  test case: 

data:text/html,<html><head></head><body style="background-color: #eeeeee"><form
name="test"><input type="text" style="width: 4in;"/><br/><input type="file"
style="width: 4in;" /></form></body></html>

Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
iirc form controls are entirely underspecified.

*** This bug has been marked as a duplicate of 52500 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.