Symbolic links should not be resolved to the real file in helper applications

RESOLVED DUPLICATE of bug 176486

Status

RESOLVED DUPLICATE of bug 176486
15 years ago
14 years ago

People

(Reporter: carsten, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)
Build Identifier: version 0.7.1 (20040626)

I install kde /opt/kde-<version> and create a symbolic link /opt/kde to the 
current used kde version. This allows me to quickly switch between different 
versions of KDE and get rid of an old version I do not need any longer. 
 
However thunderbird undermines the concept of symbolic links, when choosing an 
application as a helper application for a certain file type by resolving the 
link to the path of the real application. For example I cannot 
choose /opt/kde/bin/kuickshow for displaying images. It always transforms it 
into /opt/kde-3.2.2/bin/kuickshow. After upgrading to KDE 3.2.3 I 
remove /opt/kde-3.2.2 and had to re-setup all KDE helper applications, just 
because Thunderbird ignored the link. 

Reproducible: Always
Steps to Reproduce:
1. Create a copy of an application 
2. Create symbolic link to the copy of the application 
3. Register the symbolic link as helper application for a file type 
4. Remove the copy of the application 
5. Change the symbolic link so that it points to the original application 
5. Try to open something of the file type for which you've registered the 
helper application 
 
Actual Results:  
It cannot find the helper application anymore 

Expected Results:  
It should not resolve the path the symbolic link points to, when choosing the 
helper application. At least make the text field, where the full path of the 
helper application is shown editable, so that it's possible to overwrite it 
manually.

Comment 2

14 years ago
Agree about dupe.

*** This bug has been marked as a duplicate of 176486 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.