Lock icon doesn't appear in location bar when surfing a secure site

VERIFIED FIXED in Firefox1.0beta

Status

()

P1
major
VERIFIED FIXED
14 years ago
5 years ago

People

(Reporter: tracy, Assigned: bugs)

Tracking

({fixed-aviary1.0, smoketest})

unspecified
Firefox1.0beta
PowerPC
Mac OS X
fixed-aviary1.0, smoketest
Points:
---
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
seen on Mac build 2004-07-02-09-0.9

-goto to the given secure site URL
-look for the lock icon in the location bar

tested results:
no lock icon appears

expected results:
The lock icon appears at the right end of the location bar and is locked.

Note: this works on the builds from 0702 for Windows and Linux
(Reporter)

Updated

14 years ago
QA Contact: firefox.general → walkerrunner

Comment 1

14 years ago
confirmed on Mac OS X 10.2.8
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040702
Firefox/0.8.0+

It's caused by the checkin for bug 244025. For an explanation what's happening,
see bug 244025 comment 37 and bug 244025 comment 41. Note : it's also the
opposite of bug 248419.
Blocks: 244025
Severity: blocker → major
Component: General → Location Bar and Autocomplete
Assignee: firefox → bugs
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0+
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → Firefox1.0beta
.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

14 years ago
verified with mac build 2004-07-09-09-0.9

Lock icon appears in the left end of the status bar.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Keywords: fixed-aviary1.0
(Reporter)

Updated

5 years ago
QA Contact: twalker
You need to log in before you can comment on or make changes to this bug.