Possibility to send web page by mail with all external elements included, as attachements

RESOLVED DUPLICATE of bug 45602

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 45602
14 years ago
13 years ago

People

(Reporter: Igor Velkov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a1) Gecko/20040520
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a1) Gecko/20040520

Time-to-time it will be comfortable to send web page with all visible elements
as minimum, or, maybe, with all active content - as maximum. Outlook express can
do it.

Expected results:
When I am looking to web page, with graphics, I choose "send web page with all
elements" from file menu. 
Recepient gets my letter with html page attached, and all external images (or,
maybe, swf) in attachement, too. All links in HTML corrected to refer to this
attachements.
Then recepient can see page in original view in mailbox, or can to save that
page to local disk, like "save web page, complete" now (from web site)

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
A "simple" way to do that: just print the page to a postscript file. It would be
cool to automate that a bit, eg. by dragging the URL bar icon onto the mail app
icon. Of course, that should call an external mail app if one is defined. And
the action should be configurable, eg. "just send link", "send ps", "send pdf" etc.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> A "simple" way to do that: just print the page to a postscript file. It would be
> cool to automate that a bit, eg. by dragging the URL bar icon onto the mail app
> icon. Of course, that should call an external mail app if one is defined. And
> the action should be configurable, eg. "just send link", "send ps", "send pdf"
etc.

hm. I think a great handycap of usage html instead pdf or postscript is keepeng
a main concepts of formatting, and possibility to show a page as end user want -
page and font size, headers and footers, fonts, etc.

You can to recommend to send simply gif, jpg or png pictures of rendered pages -
result will be same, but not I want. I want that I wrote - html page with all
visible elements, sutable for viewing, printing or editing... Maybe, it will be
not html witn lot of .gif, .jpg, .js and .css files. It may be single htx
archive, containing all of it.

Comment 3

13 years ago
I'm voting for this bug.  I work in a shipping company.  My users are not
computer-savvy.  They've been mailing Web pages with IE and Outlook for FedEx
web pages that display (script-generated) shipping labels (with bar codes and
external scripts).  If Firefox can't do this, they have to print 2-3 pages and
then FAX them or return to using IE.  The ability to retrieve the Fedex label
disappears after a few days, so sending the URL doesn't work.  I'll try printing
to a file and see if that makes anything easier, but the likelihood of my users
doing something like that drops considerably with each additional step involved
in the process.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 45602 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.